Snaphu segmentation fault (core dump)

Hi,I have met an problem with snaphu in cygwin64: segmentation fault (core dump).
snaphu 解缠问题

and the snaphu.log is as follows:

I install snaphu (v 2.0.4) ,and gcc(7.4), and i have tried the solution:

by " change “#include <sys/time.h>” into “#include <time.h>”, and then compile and install again".

Also i have tried " comment out the log file line in the snaphu.conf file" in some other topic
, but the error "segmentration fault( core dump) still comes.

Also i have tried use snaphu installed on the snap (Radar–Interferometric–Unwrapping—snaphu unwrapping), the ram would jump to 99%( my computer is a server with 128G ram)。

can anybody know which causes this problem and how to fix it. I have struggled for this problem for two days. thx a lot.

Do you also get the error if you switch MCF to MST solver?

I’m not sure. I tried MST, and now 24 hours have pasted, it has not come an result, but the ram looks fine (using49%), it looks like this:

Is that normal? my interest area is 2000km2, with a pair of master and slave.
thanks a lot.

At least no error so far. The raster is quite large (25000 lines), did you set a suitable tiling and overlap? Also setting the correct number of processors can speed it up.

Thanks so much.
I think this is due i set overlap=0, though i set 12 processors, one week has passed, and snaphu’s treesize has expanded to 53866623 which seems would go on expand.
but i tried series analysis with the same area, 48 pics, the result of step(6,6) comes out in miniutes.
Thanks for your replies again, i really appriciate that.

Unwrapping in StaMPS works different because it is only applied to a network of persistent scatterers.
Please try a different tile size and more overlap.