what mode did you select? TOPO, DEFO or SMOOTH?
Try SMOOTH an see if the error persists.

I had selected TOPO mode.
Changed it to SMOOTH. Still encountering the same error.
snaphu v1.4.2
27 parameters input from file snaphu.conf (84 lines total)
Logging run-time parameters to file snaphu.log
Creating temporary directory snaphu_tiles_1260
Unwrapping tile at row 0, column 0 (pid 11304)
Unwrapping tile at row 0, column 1 (pid 18528)
Unwrapping tile at row 0, column 2 (pid 2716)
Unwrapping tile at row 0, column 3 (pid 17424)
Unwrapping tile at row 0, column 4 (pid 18268)
Unwrapping tile at row 1, column 0 (pid 15064)
Unwrapping tile at row 1, column 1 (pid 1456)
Unwrapping tile at row 1, column 2 (pid 4876)
Unwrapping tile at row 1, column 3 (pid 18728)
Unwrapping tile at row 1, column 4 (pid 16456)
1 [main] snaphu 1260 cygwin_exception::open_stackdumpfile: Dumping stack trace to snaphu.exe.stackdump
Process exited with value 35584
Finished tool execution in 3498 seconds

how much overlap did you apply between the tiles?

I applied an overlap of 200

that is a reasonable value. Could it be that the path where you execute snaphu contains special characters or spaces?
Try to move your data (and snaphu.exe) to C:\temp\ for example, and run it there.

I have tried giving different target folders. But the unwrapping outputs always end up in C:\Users*username*

C:\Users\GEO That’s my target folder… Don’t think there are any special characters here

and in the path where snaphu.exe or the S1 data is located?

I wonder how you define a target folder for the unwrapping at all? Usually the product is simply created in the same folder as the unw_phase_[…].hdr file

I have done both 1)specified it in the same folder as the input phase.img and 2) not specified an output folder in processing parameters tab, but the output files get created in C:/Users/. I have tried reinstalling snap as well. I’ve tried it on a different machine and this error did not occur there. What could be the source of this error?

where is snaphu.exe located?

Maybe one of the environment variables of your first system somehow defines C:\Users\ as the temporary scratch layer. But I have never heard of this issue before, to be honest.

That’s where snaphu.exe is located.

in one of your screenshots above I noticed that you are using cygwin?

I am not using cygwin, that was the execution output from processing parameters tab.

very strange. Are the results in the output folder reasonable at least?

1 Like

I also encountered a similar problem, and my results are the same as those shown in your diagram.How did you solve the problem in the end? Can you give me some Suggestions.Thanks!

does it also happen when you run snaphu from the command line?

Yes, the error still occurred when i run command lines,and my statistical-cost mode is SMOOTH,initial method is MCF,Tile is 10X10,overlap is 200.I don’t know why. May I ask whether this is due to the problem of software installation?

sorry, thought you have the problem with the target folders in the user directory because you replied to this post.

So what error exactly are you referring to?

I’m sorry I didn’t state my problem clearly.I have been trying to unwrap my interferogram using the SNAPHU-unwrapping plugin and I’m getting the error:
Unexpected or abnormal exit of child process 12796
Thank you very much for your reply. I’ll check it carefully about the target folders in the user directory later

I don’t think this relates to your problem then.

The “abnormal exit” error is tricky because it does not say much about the reason why snaphu is failing.
How large is your interferogram (columns and rows)?
Can you please post a screenshot of it?

It is always worth to change the number of tiles and also test the other modes (MST vs MCF).