SNAPPY Python API Runtime Error: Permission denied: connect

I have written some Python software which uses the Python API to automatically co-register a stack of Sentinel-1 data. I have seven steps in my processing chain of which applying the orbit files is the first (most of the script is shown below). I have tested the software on five different sites using small stacks of imagery (<10 images) and it runs to completion without any problems and the outputs are as I expect.

However, when I run for a larger stack (60 images) I get a Runtime Error where it seems that I cannot connect to SNAPPY (see image below). In the example below I can apply the orbit files successfully to the first 38 images before the error occurs.

N.B. the error is not specific to the dataset as I have tried with other large stacks and I get the same error at a similar point. The RAM on the computer was also sufficient and I was utilizing approximately up to half of its available capacity. I am running Python 3.6 (64 bit) through Anaconda.

Does anyone know what is causing this / have a potential solution?

Many thanks,


The last message seems to indicate something about gdal missing…

@marpet, @kraftek perhaps you have a better idea from a Snappy or gdal integration point of view…

For anyone wondering about these issues - the runtime error in the top line is resolved by importing gdal before snappy. The runtime error below (Permission denied: connect) was an issue with the firewall of the PC…

1 Like