Solved: Sen2cor DEM reference url?

Hello all,
I am using the standalone sen2cor command line tool, but the default DEM reference url in the L2A_GIPP.xml
seems not to be valid (anymore):

Trying to retrieve DEM from URL this may take some time ...
    [Errno socket error] [Errno 110] Operation timed out
    Download error %s, flat surface will be used

This is most likely related to “In January 2021 the source for SRTM 3Sec data which are automatically downloaded by SNAP has changed” ( and Snap 8 BackGeocoding in Alpine linux Docker.

I tried to replace the url by
but sen2cor seems to directly expect a .zip file:

Trying to retrieve DEM from URL this may take some time ...
File is not a zip file
DEM not available, flat surface will be used

Is there an URL available that is compatible with sen2cor?

I realize I did a mistake by not adding a final slash to the URL. It does work with

1 Like

since CGIAR updated their website, the links in Section 3.2.7 of the S2-PDGS-MPC-L2A-SUM-V2.8 have changed.

  1. The 90m SRTM Digital Elevation Database from CGIAR-CSI is now here:
  1. The SRTM CGIAR disclaimer has moved here:
  1. The address in the SUM is now


S2 MPC Operations Manager

1 Like