Spectra view

I am trying to view the spectra of my points but it does not work. First correct my image using ICOR processor then i do reprojection to the image. I don’t knew why spectra cannot view. Thank you for your support

Your bands do not have spectral information. This is the reason the values are not shown in the view.
It can be that this information is not written by iCOR.
You can enter this when right-click on a band and then selecting Properties. There you can add the wavelength for each band.

1 Like

Thank you for your reply.
I have tried the image before ICOR atmospheric correction and i can view the spectra.

But for the image after ICOR, I already added the wavelengths for all bands as you mentioned but still no view to the spectra.

I just tried it and it worked for me.
Right after editing the wavelength value the Spectrum View is updated.
Click in the Spectrum View on image
This will show all spectra of the pins.

But your report revealed another issue to me.
When editing the wavelength, the displayed name in the Product Explorer is not updated.
This will be fixed in the next release.
[SNAP-1503] Displayed name in Product Explorer is not updated if wavelength is changed - JIRA (atlassian.net)