Spectrum View not working

I have SNAP (same versions) installed in two computers.
In one computer (Windows 7, 64 bit) the spectrum view isn’t working. Even after re-installing it.
Any idea what is wrong with it?
(tried different files from different sources)

(Any other info I need to give to see potential source of problem)?

Forgot to add, that it shows the sentence ‘collecting spatial data’ - or something like this similar, but it is not.

Your working with Sentinel-2 data? Has one of the computers less memory?
Maybe if you wait a while and don’t move the mouse while then you might see a spectrum.

I cannot check now, but it might be as you said a problem of memory.
In two computers that I use, the spectrum view works, but in that one, not even waiting hours anything appears.

thank you @marpet

Hi there !

I dig up this old topic because I have the same problem. I’m working with a good computer and on a subset and I still don’t have any graph on the Spectrum View window :

I have enough space on my hard disc (more than 30 Go) and Snap is configured to go up to 11 Go of RAM as you can see below :

Any idea to solve that ?

Thanks in advance ! :smiley:


Have you saved your subset to disk? This might help. Even this not a fix, it might help for now.
Somehow, the S2 data slows down the spectrum view.

I’ve tried just before and nothing changed. I wait for 5 min on a pixel but there is still the message.

Have you tried placing a pin at a random pixel and use it instead of the one clicked on by the cursor?

Unfortunatly yes and it doesn’t work. I tried all the base manipulations and nothing works.

Same issue for me and a colleague,
both on SNAP 6 pre-release and SNAP 5, windows 10
16Go RAM
plenty HDD space
on a very small subset

Thank you

Is there any solution to the above-mentioned problem? I tried all the ways suggested above but none of them is functioning.

You are also using Sentinel-2? Do you use the latest SNAP? What are the specs of you PC?

For me it works after waiting ~10 seconds. With a rather old PC (Intel I7 and 16 GB Memory).

No, the data I am using is acquired using airborne sensors. Nonetheless, I abled to get the spectrum view.

1 Like

Good that you have managed it. Probably you had to add the wavelength information to the bands, right?

1 Like

Yes, exactly.

Hi there!!
I´m working whit subset image Landsat 8 TOA in Snap 8, Windows 10, 50gb SSD free and 32GB ram

In Snap not working. after two ours of “collecting” nou response.

In LEOWorks 4.3 no problem, the response is automatic

I need to work on SNAP, suggestions??

Tanks!! Fede

“collecting spectral information”

Could it be that it just takes some more time to display it?

Your wavelengths are not in nm. From where have you downloaded the data? Have you modified the values somehow?

Hi there,

I’m facing the same issue “Collecting spectral information…” for several minutes (no result even after 10 minutes). I’m new to SNAP so there’s a possibility I’m doing something wrong. I’ve tried to view the spectrum for both cursor and pins.

I’m using up to date SNAP on macOS Big Sur 20G527, 16 GB memory, Intel Processor. The image I am viewing is Planetscope 8 band geotiff, 25km2 subset. I can display the spectral information for the same image in ENVI 5.6 on the same machine.

Any tips would be much appreciated :slight_smile:

Sorry I have now Planetscope data at hand to verify your issue or to see what the reason might be.
It might be that the data is stored in cloud-optimised-geotiff format. This is currently not well handled in SNAP.

1 Like