StaMPS 4.1 beta Installation in Ubuntu 18.04

Had you used the updated ps_load_initial_gamma.m file I provided in the forum (somewhere around March 2019)?

I would appreciate you search for it in the forum, from my cellphone I can’t find it.

Once you are in the Execution folder, Open matlab


In the matlab set path from Add with Sub Folders

Select the Root file installed for STAMPS, It will automatically picks all sub folders.


Hope, this will resolve many of the issues.

1 Like


Can we generate DEM / Unwrap the DEM from SENTINEL-1 SLC data with the StaMPs tools ?

StaMPS is a method for the detection of surface height changes, not the absolute heights.
DEMs are mostly derived from classic interferometry. Have you seen this tutorial?
DEM generation with Sentinel-1 - Workflow and challenges

I am following the Data recipe from ASF.

What are the suitable SNAPHU export Parameters ?

There is a difference in Export parameters between both SKYWATCH and ASF tutorials.

Could you confirm the guide lines for Export parameters …!

the ASF tutorial is a bit unpractical at some points (in my opinion).

About the export parameters: There is no right or wrong - they can be changed according to the needs and outcomes of each specific case. A good start are 10x10 tiles and an overlap of 200 pixels. If you encounter problems or bad quality, please check the last page of the Skywatch tutorial where potential error sources and solutions are provided.

However, none of these points are related to StaMPS, so this does not really fit in here. So it would be good to continue discussions on one of these topics:

Hi, Abhilash, and @ABraun.

I am encountering the same issue as of the moment, and I did some of the suggestions by @ABraun as marked by the yellow box. Please see screenshot below.

I just want to ask you both how is it to be resolved? Below it is the screenshot of the 2 CONFIG files (bash and tcsh).

@ABraun, what do you mean here? If you can enlighten me.

"According to your screenshot, this worked with tcsh

But you have to edit this config file accordingly.
You need to define at least the directories of


Otherwise you cannot execute the StaMPS scripts."

@Abhilash, where and what path variables should I change?

Thank you for your assistance in advance.

in this config file you define where you installed all these files. The current paths (home/ahooper/Stamps_v3.2) do not exist on your machine.

So you have to

  • compile snaphu
  • compile triangle
  • install matlab

Then you edit the config file and enter the actual folders of

  • stamps
  • triangle
  • matlab
  • snaphu

Once this config file is updated, you have to source it as described in the manual. You have to enter the command (you tried it in the screenshot) in the directory where the file is located, otherwise it is not found.
Sourcing this config file makes all parts of the StaMPS processing available to the currently opened shell so once certain commands are callled, they are found in the folders which are entered in the file.

Some notes on this

Thank you, @ABraun!

I will do what you’ve mentioned here, and I hope to get it done correctly.

Then I have to install first the other software packages.

Thank you!

good luck - you find many useful posts on the single points in this forum using the search function!

Hi, @ABraun!

I just want to ask if I successfully installed StaMPS.

Home screenshot.

StaMPS config files (.bash and .tcsh)

I think I need to configure the files for the snap2stamps and also TRAIN. I will be using SNAP 7.0 for the interferogram preparation.

Finally, in the terminal:

Thank you!

looks good so far - good job!
Please also test triangle as a command in the linux shell, because it is required at later steps in MATLAB.

Hi, ABraun!

Sorry for the late response.

Is this what you mean?

I hope triangle works fine.

I am on my next ‘journey’ for the PSI analysis using StaMPS/MTI.

Currently, I have downloaded through the ASF Vertex 13 S1B for my pilot testing. Running out of memory. Heheh.

Also, reading some threads on pre-processing with SNAP: snap2stamps.

I hope to catch up with the discussions. I know I will face some difficulties along the process but thanks to this forum that we get solutions from experts and developers.

Thank you once again.

Hi, @ABraun!

I am doing master selection by using the InSAR Stack Overview available in SNAP through Ubuntu but it doesn’t show me the selected master image. I did click Add Opened then clicked Overview but nothing is happening.


But when doing it through Windows, the recommended master image appears.

Could you tell me if there is something wrong? Or if there’s any adjustment that I have to do?

Thank you.

@ryeramirez triangle looks also correct, well done!

The master selection helps you to select a master image with suitable capabilities. So you can determine it in Windows but still create the Stack with BackGeocoding and ESD in Linux.

I see. Then I will make use of the one obtained through SNAP in Windows and perform stacking in Linux.

I have reduced to 10 SAR images my data for now (due to disk size issue) for my first testing. I hope this is a good starting point for beginners with StaMPS/MTI.

I will proceed then with snap2stamps.

Thank you, ABraun.

Sure, testing with less data is okay, good luck!

Good afternoon, I am trying to use staMPs version 4.1, I had already used the previous version and I am having problems executing mt_prep_snap, I followed all the instructions for its installation, could someone please help me.

In the config file you define StaMPS_v3.2 as the installation folder but it is StaMPS-4.1-beta in your case.
Accordingly, your shell does not find the command

1 Like

It was that, thank you very much!