Stamps Export Error about OperatorException

Hello all

I was performing the graph for Stamps Export using GPT, but I got the error messages shown below.
Then, I also perform Stamps Export using the GUI, the same error showed up as well. (see the figure below)
I also perform it on Windows, it is still the same.
So I suspect that may be something wrong with the previous steps (Splitting, Coregistration, IFG formation). How can I check if the data is correct?

I found similar issues about the error message, but no one happened in Stamps Export.

Is there any solution for this?

Thanks in advance!

	at org.esa.snap.core.gpf.graph.GraphProcessor$GPFImagingListener.errorOccurred(
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
Caused by: org.esa.snap.core.gpf.OperatorException
	at org.esa.s1tbx.insar.gpf.StampsExportOp.computeTileStack(
	at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeRect(
	at org.esa.snap.core.gpf.internal.OperatorImageTileStack.computeTile(
	... 4 more
Caused by: java.lang.NullPointerException
	at org.esa.s1tbx.insar.gpf.InSARStackOverview.calculateInSAROverview(
	at org.esa.s1tbx.insar.gpf.StampsExportOp.writeBaselineFile(
	at org.esa.s1tbx.insar.gpf.StampsExportOp.writeHeader(
	at org.esa.s1tbx.insar.gpf.StampsExportOp.computeTileStack(
	... 6 more

Error: org.esa.snap.core.gpf.OperatorException

Better use this python code.
mdelgadoblasco/snap2stamps: Using SNAP as InSAR processor for StaMPS (

Hello @suribabu
Thanks for the comment.
Actually, I was just using the code to do the whole preprocessing procedure, and the error pops up in the last step “stamps_export”.

Have you installed Java on your PC?

Yes, sir, java is installed.

Ok then, update the SNAP latest version and try to process the stamps export step.

I had reinstalled the latest SNAP and also checked the update.
It should be the latest one.

1 Like

Hi all
I had checked if the other datasets can run the code successfully, and yes, they are.
So, it seems like the error is caused by the previous steps although the result of them looks fine.
I need to check where the mistake at step by step, and does anyone have a better way to check?

I have a look today. It’s for okie one swath. With 2 or 3 swaths, I was able to get the same error message as @hmhuang reported! It was certainly something wrong during the ‘TOPSAR-Merge’ operator for merging swaths. Only the S1tbx team can fix it, isn’t it? Look for your support indeed. Thanks in advance.

Dear @marpet @ABraun

Sir, sorry for bothering you, as @htmdinh mentioned above, could you please take a look for this?

Thank you very much!

Do you have any solution about this problem? I have the same issue.

Maybe @lveci or @jun_lu can say more about it.
A quick look at the code indicates that no slave metadata can be found.