StaMPS installation in Ubuntu

Hi there,
I am trying to install StaMPS in Ubuntu, I do not have experience in Linux, I followed the tutorial but no way to install it. Could you please, help me to do that?


It would be easier to help if you tell us what you already did and at which step you struggle.

Hi Andreas,
I wrote in the terminal “make” and after that I wrote “make install” (check the figure), how to be sure that the StaMAPS is installed? is there some commends is missing?

Best regards

Looks fine to me!

Thanks, How to be sure that the StaMPS is installed?

try to execute one of the compiled scripts from the bin folder. But not the exe scripts but the other ones like mt_prep. Just type it in. If the help is displayed they should work.

Please have some looks here if you are new to Linux:


Many thanks dear Andreas, really I appreciated your help.


Hi Andreas,
I tried to execute “mt_prep” as example but this command was not found (see the figure), that mean is the program not installed, right?


Hi arsalan
I also have this could you fix it? Pls help me

Please read this thread carefully, I think your problem is solved there.

Dear thho,
please help me in Stamps installation and PSI processing. Please let me know what to do after these steps shown;

Hi all.

I am new to the forum, I have reviewed many of the publications that have been published here and have been very useful in solving some problems. Now I have one that I have not been able to solve.

I’m trying to install StaMPS to do PSI in Ubuntu, I follow the manual but I can not do anything, I’ve stayed in the first command.

Could someone help me with this? I would be very grateful.

thank you to all.

this is not StaMPS related, you need to configure your compiler in the makefile or install g++:

Thak you very much @ABraun It is very useful to my academic project for measure the vertical displacement over terrain Mexico city airport. I have solved my problem with g ++, I’ll continue with installation process reading all in this topic or other topics about StaMPS installation in ubunu to PSI, it is really great this forum.


1 Like

well done!
Getting into compiling in Linux took me some time as well when I started, because I rarely used it before StaMPS, but I think it is managable when consulting some forums or tutorials.

Where should we put the following folders? when we can install Stamps and run mt_prep_gamma ? i used cygwin64 and Ubuntu.

thanks a lot


I have installed new StaMPS/MTI (4.1b1) version. When I run the mt_prep_snap command I get some errors:

volkan@volkan:~/Desktop/PSI/INSAR_20180807$ source /home/volkan/StaMPS-4.1-beta/StaMPS_CONFIG.bash
volkan@volkan:~/Desktop/PSI/INSAR_20180807$ mt_prep_snap 0.4 3 2 50 200
mt_prep_snap Andy Hooper, August 2017
Amplitude Dispersion Threshold: 2
Processing 50 patch(es) in range and 200 in azimuth
3/*slc/0.4.*slc.par: No such file or directory.
3/*slc/0.4.*slc.par: No such file or directory.
ls: cannot access '3/*slc/*.*slc': No such file or directory
@: Assignment missing expression.

How can I fix the problem? Thank you.

mt_prep_snap needs to know the date and location of your data exported from StaMPS.

Please see my example here: Linux Installation using StaMPS and S-1 data

I solved the problem. Thank you Andreas.

Best wishes.

1 Like

Dear Volkan, can you share the solution please