StaMPS is unable to write files

My installation was fine till today. I have used StaMPS previously and everything worked. But today, I started a new processing, and I wanted to change parameters before starting. But this error occurs:

>> setparm('scla_deramp','y')
SETPARM: scla_deramp = y
Error using save
Unable to write file parms: Sistema de archivos de solo lectura.

Error in setparm (line 181)

where “Sistema de archivos de solo lectura” means “Read-only file system”. Same error arises if I run stamps(1,1) for example.
I have tried to change permissions, but feels like I do have them.

Any idea what could be wrong?

If linux detects a problem with a file system it will mount it in read-only mode. If you don’t know about this you should review a system administration manual for your distribution and ask any remaining questions in a distro forum. Beware of quick and easy “fixes” you can find with internet searches — never run a command without understanding what it is supposed to do and what permissions it requires.


Thanks. So this is not a StaMPS problem, so I close the issue.