StaMPS processing error

Hey Abraun,

I changed it using setparm option, but I did not change the values in the ps_plot.
I will try that. Thank you for your input.

It will be nice if you can give the input for the other question on ps_plot(‘v-dao’)

With regards
Narayanee

you can only use the a flag (in “v-toa”) if you have performed atmospheric correction using TRAIN or GACOS. If this is not the case, you can only plot “v-to”.

Thank you. I will look into it.

Same here, did you fix it?

I’m having the same problem, any luck?

Hi,

try to set setparm(“merge_resample_size”,0)
and run again stamps(5,5)

stamps(5,5) command didn’t executed due to following errors:

STAMPS: Will process patch subdirectories
STAMPS: ########################################
STAMPS: ################ Step 5 ################
STAMPS: ########################################
STAMPS: Directory is PATCH_1

PS_CORRECT_PHASE: Starting
Correcting phase for look angle error…
GETPARM: small_baseline_flag=‘n’
PS_CORRECT_PHASE: Finished

STAMPS: Directory is ulaanbaatar

PS_MERGE_PATCHES: Starting
Merging patches…
GETPARM: merge_resample_size=0
GETPARM: merge_standard_dev=Inf
Processing PATCH_1
Index exceeds matrix dimensions.

Error in llh2local (line 41)
dlambda=llh(1,z)-origin(1);

Error in ps_merge_patches (line 485)
xy=llh2local(lonlat’,ll0)*1000;

Error in stamps (line 474)
ps_merge_patches

Is there any solutions.?
ps_parms_initial.log (2.6 KB)
STAMPS.log (36.9 KB)

Try this below one.

1 Like

solved by myself.
stamps should be run in PATCH directory. :upside_down_face:

1 Like

Not sure what you did… but if you run StaMPS within the INSAR_XXXXX folder, it takes cares all the subfolders and so on.

Probably you run step 5 or so within the PATCH folder, which lead to the issue you reported.
Happy to see that you solved it. This is the best part of it.
Enjoy StaMPS

hello I have the following error in step 8 of the processing with Stamps:

Index in position 1 exceeds array bounds (must not exceed 30350855).

Error in ps_scn_filt (line 179)
xy_near=ps.xy(ix1:ix2,:);

Error in stamps (line 540)
ps_scn_filt

I use PAZ images and the following parameters:

Bridge

(extremely educated guesses by BW and MS)

Parameter Default Used
max_topo_err 20 10
filter_grid_size 50 40
clap_win 32 16
scla_deramp ‘n’ ‘y’
percent_rand 20 1
unwrap_grid_size 200 50
unwrap_time_win 730 88
scn_time_win 365 88
scn_wavelength 100 50
unwrap_gold_n_win 32 16

can someone help me to solve the error?

I have the same problem , tried with setparm(“merge_resample_size”,0) but still not working

I have got this message during step 3 in some of the patches
“Warning, not enough random phase pixels to set gamma threshold”

And in some patches, very few pixels were initially selected, leaving nothing after the weeding step. Should I increase the selection density and repeat the whole process "stamps(1,4) for all patches? or only re-do steps 3 and 4 so that the files 2.mat files will be overwritten?

Here’s Patch 27, 21 logs
STAMPS_patch27.log (16.0 KB)
STAMPS_patch21.log (16.0 KB)

Just increase the amplitude dispersion value to 0.42.

I appreciate it. what if some of the patches have interferograms already initially deficit of pixels because the area they represent is pre-dominant by water body



There will rarely ever be any ps pixels left for weeding. Shall I continue processing and ignore those areas? or must I try the best to subset away water bodies during the pre-processing ?

After merging Is it possible to view the patch gird with each’s number on the merged scene in order to identify why some patches are devoid of PS during weeding ?
like this


I have a water body in my study area and it’s what most likely causing a particular patch to have no PS points left after steps 2,3.
Also, will continuing merging this PS-lacking patch cause problems in further processing, or may I leave it as is?

Hi. Does anyone know what is causing the error shown below?

And, do you have any recommendations on how to fix the error?

@ABraun @thho

Thank you.

Hello everyone,
I’m facing this error in step 8 of stamps(1,8). Did someone face and solved the same issue?

Thank you.

My best regards,
Othmane.

image

First try to install triangle using this below command and run the stamps(8,8) step once again,

sudo apt-get install triangle-bin

@suribabu very thanks, it works!!
my best,
Othmane.

1 Like