Strange artifacts from coherence map processing

Hi everyone,

I have been trying to use s1tbx to generate coherence maps over different regions. Almost every time I try to do this, I get strange artifacts in my final coherence maps. I will include some general screenshots below and then focus in on a specific case. Most of the time, they have large stripes of no data in somewhat random orientations.

Here’s an example of one over Vadodara, India with a lot of stripes and some odd bands in the leftmost swath:

Another odd one over Sydney recently:

I process most of these with a bash script I wrote. However, for the case I want to focus on, I processed the image in the SNAP GUI to eliminate any error that may be coming from my script. This will be a coherence map over two Vadodara scenes:

  • S1A_IW_SLC__1SDV_20200602T010224_20200602T010251_032831_03CD82_0CDA
  • S1A_IW_SLC__1SDV_20200614T010225_20200614T010252_033006_03D2B4_1D9D

I did not use the graph tool to process this, but here is the graph of my processing to get an idea of my processing steps:

Instead of processing this with the graph tool, I clicked through all the menus in the GUI and manually set the parameters. I split subswath 2 and only processed VH. For multilooking, I used 7 range looks and 1 azimuth look. For Back-Geocoding, I used SRTM 3Sec (Auto Download) for my DEM. For my orbit file, I used Sentinel Precise (Auto Download). Other than that, I believe I used the default parameters.

Now, there is something a little strange about my situation. I am trying to process these on a lab machine with RHEL 7.7 and 32GB RAM. Since this OS doesn’t have GLIBC_2.23, I had to do some of the processing in a docker image with Ubuntu 20.04 as a work-around. For this case, I had to run Back-Geocoding and Coherence in a docker image using command line.

Anyways, here is my final result. You can see there is a stripe artifact at the top:

I ran the same processing steps (all with GUI, no docker) on my own computer with Ubuntu 20.04, 16GB RAM and did not get that artifact. Here is that:

Any idea of what I may be doing wrong? Let me know if you have any thoughts or questions!


these are very strange and irregular, so probably not related to the data itself. Still, can you please try to

  • use SRTM 1Sec instead of 3Sec for BackGeocoding
  • add ESD after BackGeocoding which refines the coregistration accuracy
  • write some of the intermediate products to a separate file to check at which step these lines are introduced

Did you maybe select an uncommon coordinate reference system in the Terrain Correction step?

Thanks for your reply.

I did keep the intermediate products for this one. In this case, it looks like the line is introduced in the Coherence step, which I had to process in the docker container. I tried running this same step on my Ubuntu computer and I did not have the problem.

I think I will process some other images and keep the intermediate files to see if it is always the Coherence step that is causing the issue.

Should I still try using ESD?

whenever you use more than one burst, ESD is a good choice to improve their registration.

1 Like

I processed a stack of 13 coherence images last night and 2/13 of them had the stripes. I saved the intermediate products this time and saw that the stripes are the result of the Coherence processing step. I believe I am using all of the default parameters for this step.

Do you have any suggestions on why I’m having trouble with this step?

We have tried your processing steps but could not repeat the problem. Can you check the intermediate result of each step and see at which step the artefacts were introduced? That will help us debug the problem. Thanks