Strange Results iCOR in SNAP on Landsat 8

Hello iCOR users,

Sometimes when I process Landsat 8 images using the iCOR tool I get some strange results (see below). Does anyone else have this problem or know why it happens?


Update since I posted this:
The results are fine if I select the BEAM file format on the SNAP tool. However, when I select GeoTIFF I get the results above. Even more strange is I did not have this issue with the real time (RT) product, just the Tier 1 (T1) product. So my work-around is to output a BEAM file and then export to GeoTIFF. I would appreciate any insights on this if someone figures out why this happens.

Had you tried to use it on command lines, running the iCOR standalone instead the call from inside SNAP?
I have processed several Landsat 8 and Sentinel-2 without problems.

If you feel just pass me the Landsat 8 filename and I will try it to see which if the result I get…

Thanks for the suggestion. In the end I got it to work, but I will try the python script if I have this problem again.

Dear Courtney

Do you have similar strange patterns when you open the ICOR output data in for instance QGIS. If so, can you provide the scene details for which you are getting the strange stripes so we can verify it ?

Please note that iCOR only works with data in the original input format. It will not work on data converted to BEAM file format first.

The ICOR team


Yes, the same pattern appears when I opened the image in ArcGIS. The name of the raw image I used is “LC08_L1TP_019036_20181024_20181031_01_T1” . I did not convert it to another file type prior to applying iCOR within SNAP. I obtained the striped image when I selected GeoTiff as the output file format, but did not have any issues when I selected the BEAM file format.

Thanks for looking into it,

Dear Courtney

We processed the scene with the default iCOR setting but we don’t get the strange artefacts when we open the image directly in SNAP.

Did you install the iCOR patch for SNAP6.0 ?

The iCOR team

1 Like

Yes, I installed the patch and I also used the default settings. Did you use the BEAM output file option or did you also try geotiff? It works fine if I select the BEAM output file option, but it just does not work when I select geotiff option. It’s not really an issue for me since it works with the BEAM file, but it took some trial-and-error to figure this out and others might have the same issue.

Thanks for your support and looking into it.