Subset malfunctions in Graph Builder

I have a serious issue with the subset tool of SNAP. In the Graph Builder I have a process that is supposed to create an output based on the coherence value of two Sentinel-1 images to a specified region.

I copied the coordinates to the specified text box in the Subset tool and my issue is that the generated image is geographically incorrect.

I also tried to use “Spatial Subset from View…” which provides suitable results, although the graph without the Subset tool processes extremely slowly.

In the “World Map” view, where the bounding box of a certain image is visible, I noticed that the extent of the graph-processed image is the same as the original Sentinel-1 image(s) and the rendering of the image starts from the top-left corner of the extent hence the geographical placement in incorrect.

The issue seems to be that the Subset tool in the Graph Builder doesn’t change the extent of the processed file according to the given geographical coordinates, instead it keeps the extent of the original, unprocessed Sentinel-1 image.

Is there any solutions for this issue?
I tried the Land/Sea Mask tool, but it makes the processing time extremely long.


it is better to hand a WKT of your area of interest over to the subset operator.

You can generate it here:
and then insert it into the field for “Geographic Coordinates” and hit “Update”.