System crush when I click on the folder icon

We installed SNAP system in 2 different PCs.
When we click on the folder icon (left up) the system crush
I’ll be happy to any idea that can solve this issue
Thank you

Does it happen on both PCs? What is different between both?
Update Java on both machines.

It’s happen in both.
I updated the JAVA

C:\Users\elad>java -version
java version “1.8.0_45”
Java™ SE Runtime Environment (build 1.8.0_45-b14)
Java HotSpot™ Client VM (build 25.45-b02, mixed mode)

Thank you

I’ll be happy to get any idea how to solve or investigate this problem
Thank you

Updating the Java version of the system will not help, because SNAP brings it’s own Java version.
Is your user account somehow restricted?
Which version of Windows do you use?
Does the same happen when you use File/Open Product from the menu?

Please select from the menu Help/Show Log Directory
Afterwards, click on the Open icon.
Hopefully, there will be something written into the messages.log file. Attach to your next post, please.

My account is not restricted
I’m using with Windows 10
It’s happen the same even from File open product
I add to this post the log file

Thank you very much for your help

messages.log (68.3 KB)
messages.log.1 (68.2 KB)

There is nothing strange visible in the logs.
I guess you tried to reinstall SNAP already, right?

Yes, 2 times

Same issue, SNAP 6.0 crashes (just closes) upon file>open product. Also stops at 50% when attempting to download ESA SciHub library in the product library window. Windows 10, updated, running as administrator.
I don’t see the environment variable in the system information, was supposed to be written there during installation.

Tried reinstalling, tried comparability test, tried rebooting. There are a number of menu items that cause the quiet crash when clicked. Otherwise, looks like very useful software.

Windows Program Compatibility Troubleshooter reports “not compatible”.

I have the same issue on Windows 10, 64bit. For each crash a hs_err_pidXXX.log file is generated. Any idea why this happens?

hs_err_pid11336.log (43.7 KB)

It seems that SNAP is a victim of a Java/Windows bug.
The same issue is discussed here:

There it is said, setting the property

You can add this property to the default options of SNAP.
Open the snap.conf file in the etc folder of the SNAP installation directory. You need admin rights.
There is a line starting with default_options. Add the above option to this line but prefix it with ‘-J’ as it is done for the other properties you see in this line.
I can’t test it, because I don’t have this issue. But in the discussion linked above it is said that this will solve the problem.
Another way to fix it, could be to install a recent JAVA JRE on your system and replace the jre folder in the SNAP directory. Just copy the installed jre folder and remove (or rename) the old one.

I have a Windows 10 x64 machine. Installed Java is jre1.8.0_161 (dated January 2018).

I loaded snap 6.0, tried 1) putting a copy of existing jre over that installed in snap subdir. That way, I got a Java error on program start, said I need 64-bit java and closed. Then 2) I replaced the snap install subdir of jre and added -J-Dnet.filebot.UserFiles.fileChooser=JavaFX to the snap conf file. That started, but misbehavior is unchanged, select open>product and program crashes (just goes away).

The Java website says they have stopped upgrading JRE, without Oracle membership (?). Maybe the problem is I haven’t paid dues to Oracle?

Upon installation, Snap asked, but did not write an environment variable to config.sys. If I had the environment variable string, I could try putting it there?

Just found I changed the Look and Feel to Nimbus, and now the file open dialog works. Didn’t have time to run anything else.

1 Like

Thank you dieli!!! On the Snap menu bar, select Tools > Options > Appearance > Look and Feel > Nimbus. Then there is an icon in the lower right corner of the main screen to update plugins. Can also restart the application at that icon. I tried the other look/feel options, Windows and Windows Classic caused the crash.