Terrain Correction bug?

I just processed a set of ALOS PALSAR FBD level 1.1 scenes and followed the sequence:

Calibration --> Multilook (1 rg, 5 az) --> Co-registration --> Multitemporal filtering --> Deskew --> Range Doppler TC

In the Range Doppler TC module I never managed to specify the exact pixel spacing I want (15.0 m), the value keep on changing to 15.9 m. Also, in the end the terrain corrected images were far from being correctly geocoded when compared with Landsat data.

Has anyone followed the same approach (or similar) and found out the same problems?

Many thanks and best wishes

With ALOS you should use the SARSimulation Terrain Correction
Also, I’m not sure if it would affect it but, you could try doing the
deskew before mulitlook.

See the ALOS ortho tutorial here

Thank you,

I followed your suggestion but when running the SAR-Simulation TC module I keep getting the following error:



Tried the SAR-Sim TC many times with different combinations of window sizes and I keep getting the same “java.lang.NullPointerException”.

The input is an ALOS PALSAR multitemporally filtered and coregistered stack of 9 FBD scenes that were previously calibrated, deskewed and multilooked (1 rg, 5 az).


It is a bug recently introduced due to the re-organization of the
software. It has been fixed and the fix should be in next release.

Thank you,

However, I managed to terrain correct my SAR data using another software and I wanted to apply a multitemporal filter. So, I have this BEAM-DIMAP stack with 18 terrain corrected bands and when applying the filter I get an error: “image requires a unit”. I tried to edit each image but it doesn’t update the field corresponding to the unit value.


On 12/10/2015 1:22 PM, jmbcarreiras wrote:

junlu, were you trying to reply to my question?

Yes. You can right click on each band and select properties in the menu. Then give the band a proper unit such as amplitude or intensity.

Thank you, the “Unit” field displays “null value”, but when I edit and change it to intensity the “Name” field changes to intensity and the “Unit” field remains as “null value”.

Where are you importing this from? It doesn’t look like ALOS bands
produced by our reader.

I created an image stack of TC ALOS images in ENVI, imported it into SNAP and saved as BEAM-DIMAP

Same error in SNAP 2.0-beta-08 when running the SAR-Simulation TC module: “java.lang.NullPointerException”

Same error in SNAP 2.0-beta-08 when trying to edit each image as it doesn’t update the field corresponding to the unit value


    Open the *.dim file with any text editor and under:
    add a line between:
         <DATA_TYPE>float32</DATA_TYPE> and <SOLAR_FLUX>0.0</SOLAR_FLUX>

    called <PHYSICAL_UNIT>intensity</PHYSICAL_UNIT>

do the same for each band (BAND_INDEX) in your *.dim file. In this case my bands were saved as floating point and each band had “intensity” units.

1 Like

Is there any way to preserve or create terrain corrected i, q rasters?
I would like to orthorectify and keep the complex image (i, q) in order to do some polarisation with the complex data in PolSARPro. I would rather have the complex imagery orthorectified.
But I also got this “java.lang.nullpointer” error while processing SarSim using i and q.
I suppose If it werent for the nullpoint error I would also get only Intensity.
Could you explain why is that? Why the real and imaginary part lost during orthorectification?


It is necessary to perform interpolation during orthorectification. Since the phase of a complex SAR image is random and noise-like, how should one perform such interpolation and would the end-result be valid?

1 Like