Terrain Correction with Copernicus DEM

Hello I am having an error while using Copernicus DEM in the SNAP Terrain Correction in GPT with S1 SAR data.

The error is the following:

Exception: Graph execution failed (exit code 1)

I have tried with both Copernicus 30m Global DEM and Copernicus 90m Global DEM.

It seems there is either an issue in accessing some tiles.

Downloading https://copernicus-dem-90m.s3.eu-central-1.amazonaws.com/Copernicus_DSM_COG_30_S01_00_E118_00_DEM/Copernicus_DSM_COG_30_S01_00_E118_00_DEM.tif to fulfill search of area -1.0, 118.0 at specified resolution 90
org.esa.snap.core.gpf.OperatorException: GeoTiff imageReader not found.

Below the portion of GPF graph:

Terrain-Correction false false Latest Auxiliary File Copernicus 30m Global DEM BILINEAR_INTERPOLATION true 0 BILINEAR_INTERPOLATION Use projected local incidence angle from DEM Use projected local incidence angle from DEM AUTO:42001 true false 0 20.0 false false false false false false false true false 0 0

I have tried with both Copernicus 30m Global DEM and Copernicus 90m Global DEM.

Could you please advise on this topic?

Thank you in advance

1 Like

It seems that there is another issue with SNAP for using Copernicus DEMs in TC step. I can read them in SNAP, but when I get output DEM I see it doesn’t convert the heights to the Ellipsoidal heights (h). Based on Help (which probably needs an update), even Aster is not converted. I haven’t tried all Global models, but using external DEM was OK and heights were converted using EGM96 geoid model. Hope this issue is resolved in new Software update. Thanks.

Sorry, this is not clear to me: You used Copernicus DEM and selected the option “Apply Earth Gravitational Model”, and then the heights were not correct?

Sorry, if it was not clear. That option (Apply Earth gravitational Mode) is only for external DEM, and not for Copernicus DEMs. Please see the attached screenshots from SANP. IT doesn’t apply Geoid model automatically for Copernicus DEMS. I think that option should be visible and applicable for all DEMs. Hope you can fix it please. Thanks.

thank you for clarification. Actually, I’m not quite sure about this. Maybe @jun_lu or @lveci can clarify if the EGM option only applies for external DEMs.

Can you please share a link where it is stated that the Copernicus DEMs require the application of EGM96?

Thanks. I don’t have any link which says which elevations these models present, but I know elevations in such Global models are relative to the Geoid. For calculations in SNAP (TC for example), they should be converted to the ellipsoidal heights (using Geoid model). I noticed, in my study area, the numbers at some sample points with known heights (both H and h), the Pixel info shows the H value (relative to the geoid, not h (relative to ref. ellipsoid). This means to me they need to be converted. Hope that helps.

According to Copernicus DEM Product Handbook, the vertical reference datum is the Earth Gravitational Model (EGM2008). Therefore, EGM96 should be applied to the DEM in Terrain Correction. A ticket has been created to track the problem (https://senbox.atlassian.net/browse/SITBX-849)


Perfect, thanks.

The problem has been fixed. The fix should be in the next release. Thanks for reporting the problem.

1 Like

Ok, so it is a known problem. Please just let us know to which version of the software we would need to update SNAP to test the new release of TC with Copernicus DEM.
Thanks for your help,

1 Like

At present, this problem still exists. When can it be repaired?

1 Like

The problem seems to be present in 8.0.3

When will the fix to this problem be released? Note that this problem exists for terrain flattening as well as terrain correction as noted above: in both case, option to remove EGM only exists for External DEM.

Still wondering when there will be a fix for this issue. Using gpt, “Copernicus 30 m DEM” works correctly for “terrain correction” but does not work for “terrain flattening”.

Here are some of my observations about the Range Doppler-based Terrain Correction in the latest version of SNAP 9.0.0 using one Sentinel-1A SAR image and one ICEYE Spotlight SAR image:

  1. If I go with the option of “Copernicus 30m Global DEM (Auto Download)”, it works fine. The tool will download a copy of the original Copernicus 30m (in tiles) to a folder like this “auxdata\dem\Copernicus 30m Global DEM”. NOTE these DEMs are still with original vertical datum (i.e., with EGM2008).
  2. If I go with the option of external DEM and select a local Copernicus 30m DEM file already with WGS84 ellipsoidal height, without checking “Apply Earth Gravitational Model”, the outputs will have some geolocational offsets despite that the online help says the external DEM “must be with geographic coordinates (Plat, Plon, Ph) referred to global geodetic ellipsoid reference WGS84 (and height in meters).”. Also tried to checking “Apply Earth Gravitational Model”, which did not make any differences.
  3. If I go with the option of external DEM and select a local Copernicus 30m DEM file that is still with original vertical datum (i.e., EGM2008), without checking “Apply Earth Gravitational Model”, the outputs are the same as the ones from “Auto Download”.