Terrain Flattening Black Areas

did you use an automatically downloaded DEM or one of your own?

I used the automatically downlod SRTM 3sec and Bilinar Resampling method.
I am using IW data. My prior steps where:

  1. Slip to IW2
  2. Apply Orbits
  3. Subset
    4 Radiometric Cali
  4. Terrain Flattening.

I tried other resmapling method ans the result is the same

try the SRTM 1 Sec instead, it can also be downloaded auomatically.
Maybe the 90m SRTM is of no good quality in your region.

I have tried with that DEM, but the results are the same. in a particular area it just make a hole with 0,00 values.

you can display the DEM by right-clicking on your SAR band and > add elevation band. It will then be downloaded and stored as an additional band. Open it to check if it is complete and has no errors.

Helo @ABraun:
I did what you suggested, it doesnt seem to be an error on the DEM generated.

How ever in that same area all those pixels are black.

Another thing that I would like to add, is that I have the same scene for 3 different dates and is only in one date that is chopping this part off. The images have all the same geometry.
Kind Regards

that’s strange.
Flattening is performed on the illuminated area, not on the incidence angle. But I can’t think of a reason why the calculation could fail at this location.

Could you provide the product names and I’ll try to reproduce it? Thanks

Of course:

The product that is giving me this error is:

From this product this are the pre-steps I use before the Terrain Flattening

  1. Split to and use only IW2 VV
  2. Apply Orbit Files
  3. Deburst
  4. Subset to obtain a smaller area of interest
    Coordinates: 42.793,13.199 42.608,13.341
  5. Radiometric Calibration for beta naugh
  6. Terrain Flatteing STRM1Sec Bilinar Intepolation

I think you need to multilook (15x4) the image first before applying TF with SRTM 1s DEM. This is to make sure that the DEM resolution is higher than that of the image.

this sometimes appears as an error when the two resolutions are different. But I don’t think it explains the holes in the image after (predominantly successful) terrain flattening.

Yes, plus on previous dates of the same area, the Terrain Flattening was succesful too. I hope @lveci can replicate the error, as the DEM is produced with no issues.

The problem occurs with the ‘non-regrid’ method. We plan to deprecate this method in favour of re-gridding. Currently however, the regrid method forces you to multilook excessively to the point that both range and azimuth resolution are less than the DEM.

1 Like

dear @lveciI
I have images from TerraSAR 3m resolution And would like to apply terrain flattening and then Terrain Correction. Which DEM will do the job better? 3 or 1 sec? Kind Regards

Ideally the DEM should have the same resolution as your SAR-data. Use the better SRTM and see if the result is good enough (you’ll have a factor of ten difference in resolution…)


I have a theoretical question. I have done coherence estimation analysis and compared the coherence between pre and post earthquake in Italy.
I used Sentinel1A data and for my pre-processing I used the SRTM1 DEM. This DEM is 30m resolution. For the same area today I got a 10m DEM.
Now my question is if this difference in DEM’s will produce different results in coherence as well as for example backscattering values?

Thank you

What is the recommended solution for the issue of black blocks in the middle of terrain-flattened Sentinel-1 images? Excessive multilooking is not a solution. I have tested 5m resolution DEMs with ‘non-regrid’ which fails with null pointer exception. There is no change with version 6.0. I am working with S1A_IW_GRDH_1SSV_20160526T194932_20160526T195003_011434_011670_F15D

Additional information: The minimal process is read-calibration-terrainflatten-write. Using various downloaded, or my DEM achieves a similar result. DEMs do not have zeros or fill values. 10 of the 47 S1A, relative orbit 162, images over the mountains near Port Moresby, have large black blocks in the same or similar areas of the terrain-flattened images. Most of the others have no defects, except a few that contain much smaller defects near shadow areas. Below is a small subset of the 20160526 flattened image.


1 Like

some black areas are introduced when 0 is set as a NoData value in the Raster properties. If these zeroes are processed they are treated as NoData and sometimes get larger (when resampling is involved).

There are no NoData areas in our DEMs.

Don’t use the original method. It should only be ‘re-grid’. When processing a tile, snap retrieves the dem over the area that should cover the tile. With SAR and mountains, considerable overlap may be needed. The artifacts look like there wasn’t enough dem for that tile. We would need to increase the amount of dem overlap or make it a parameter.