[Terrain-Flattening] The DEM resolution is lower than that of the source image

Use of SRTM 1arcsec DEM with Sentinel-1 GRDH images was possible with SNAP 3.0, and results were acceptable.

SNAP/S1TBX 5.0.x now reports: The DEM resolution is lower than that of the source image. Please multilook the source image or use higher resolution DEM (e.g. SRTM 1Sec HGT) to make sure the DEM resolution is higher than that of the source image.

A possible workaround may be to up sample the DEM to 0.5 arcsec. However, we may revert to SNAP 3.0 since Terrain-Flattening of Sentinel-1 GRDH worked fine there.

1 Like

probably the Re-grid method (slower) option is checked by default
so uncheck and probably should work…

That is exactly it. You solved two problems. If re-grid is checked, external DEMs are not accepted. So my workaround up sampling the DEM did not work. With re-grid unchecked, 1arcsec DEMs (lower res than the image) are accepted, and also my other external DEMs are accepted. Thank you.


I was mistaken about external DEMs being accepted as a result of the change. After some testing I found that external DEMs (at least mine) are accepted only when just SNAP and S1TBX are installed. I think S2TBX may have a similar module that does not work for reading external DEMs.

I’ve tried Tiff as an external dem in the terrain correction with the S2TBX readers available but, didn’t have a problem.
What external dem file are you using? What does the filename look like?

Removing the “re-grid method” checkmark also solved it for me.

Apologies for not following up on this issue. LZW compression of my external DEMs caused the failure. The work around is to decompress the TIFF. The error from SNAP is: “Problem reading DEM: null”