Terrain flattening with T3 error


when i am trying to do terrain flattening after importing my Radarsat2 data, calibrating with complex output, polarimetric matrix generation to T3, i get the following error:

A problem occured during target initialisation.
Message: The product “xxxx” already contains a band with the name “Gamma0_T12_real”.

The error is gone, when i am not calibrating the data before generating the T3 matrix.

A “workaround” is to set the flag for calibration (line 380 in the dim-file) with a text editor from 1 to 0 before the terrain flattening step. Then the terrain flattening is working.

Is this a bug? Because in the forum it was clearly stated that you have to do a calibration with complex output before generating the T3 matrix.

Thanks for your help and best regards


If you calibrate to Sigma0 with complex output and then create a T3, I believe you get T11, T12_real, etc. without Sigma0 in the band name.
I’m not sure how you got the Gamma0 in the band naming. This may be bug in the matrix generation where it may not handle gamma0.

Thats right, i get T11, T12_real, etc. without Sigma0 in the band name.

Where the “Gamma0_T12_real” in the error message is coming from, i have no idea, it can not be found in the bands. One additional thing: the “xxxx” from my first message is the name of the output file of the terrain flattening step and not the name of the input file to the terrain flattening step.

Do i have to report this as a bug? Thanks again!

What was the order your processing chain?
calibrate complex, T3, terrain flatten?

Yes, this is the processing chain.

Ok, found the bug when handling T3 and calibrated. Should be fixed in the next update. Thanks.
For now, if you don’t calibrate it should work.

Thanks! When is the update planned? Ther was already an update (today), but only the s3 toolbox was updated. Using uncalibrated values is no option of course.

I am having a similar issue as well. I am using gpt with the following xml file. I am getting this error:

INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start
The Product ‘RS2-SLC-FQ4-DES-22-Oct-2009_11.30-PDS_00590320_Cal_TF’ already contains a band with the name ‘Gamma0_Beta0_HH’.

Error: [NodeId: Terrain-Flattening] The Product ‘RS2-SLC-FQ4-DES-22-Oct-2009_11.30-PDS_00590320_Cal_TF’ already contains a band with the name ‘Gamma0_Beta0_HH’.

I ran this graph before and it worked great, this is a new issue. Cal_TF_ML.xml (1.8 KB)