There is already an image reader - ALOS-2 level 1.1 geotiff

I have a number of ALOS-2 products (level 1.1, geotiff) that I would like to process. I understand CEOS format would be better but this is not an option unfortunately.

I run into an issue at the first step and cannot open the products in SNAP. Either by using ‘open product’, or ‘Import’>‘SAR sensors’> ‘ALOS-2 GeoTIFF’, I get the same error ‘there is already an image reader’. (error log below).

I have managed to open it as a generic GeoTIFF, but I then cannot perform any calibration or correction as it is not a SAR image.

Any help or guidance would be much appreciated!

messages.log (241.4 KB)

java.lang.IllegalStateException: There is already an image reader.
at org.esa.snap.dataio.geotiff.GeoTiffProductReader.readProductNodesImpl(
at org.esa.snap.core.dataio.AbstractProductReader.readProductNodes(
at org.esa.snap.core.dataio.AbstractProductReader.readProductNodes(
at org.esa.snap.core.dataio.ProductIO.readProduct(
at org.openide.util.RequestProcessor$
at org.netbeans.modules.openide.util.GlobalLookup.execute(
at org.openide.util.lookup.Lookups.executeWith(
[catch] at org.openide.util.RequestProcessor$

Jira ticket SNAP-3631 created