Thermal Noise Removal not working from March 2018 - SLC products

Hi all,
I am facing the problem of Thermal Noise Removal error, on Sentinel 1 scenes (SLC products) collected after March 2018.
I have the SNAP 8 version installed and I want to process SLC S1 data (downloaded from ASF), from 2017 to 2019. In 2017 I have no issues in the batch process I run. Starting from March 13th I cannot process the images with the same batch process and I encounter the error in the Thermal Noise Removal Step. The error appears (both in the batch process and in the manual process), when the Thermal Noise Removal Step is run (after the steps of TopSAR Split and Apply Orbit): ‘A problem occurred during the target product processing. Type:OperatorException Message:null’.
Moreover, sometimes, when I run the process in the step-by-step mode, in the Thermal Noise Removal step the software does not automatically update the name of the image being processed, therefore asking if I want to overwrite the _Orb file just created in the step before. I send a screenshot of this problem as well.
I attached the screenshot of the errors.

I read several posts on this topic, all related to a few years ago! However, I am still facing this problem now, which seems not solved even with the latest SNAP version available.
Do you know how can I solve this problem and why does it occur? I did several tests, using several dates and both ascending and descending orbit. Only for very few random images following March 2018, I was able to complete the process.
Thanks a lot for any help and suggestion!
Kind regards
Giulia Marchetti


Have you installed all updates to SNAP 8?

Yes! I have installed all updates available…

We will look into it. A JIRA ticket ([SITBX-891] Thermal Noise Removal not working from March 2018 - SLC products - JIRA) has been created to track the issue. Thank you for reporting the problem

We have looked into the issue. Basically we have downloaded the same product and processed with the following steps: TopSAR Split, Apply Orbit, Thermal Noise Removal as you did in your processing. Unfortunately we cannot reproduce the problem (see image below). If you can provide more details such the parameters used in each step, we can look into it again. Thank you

Thanks a lot, Jun_lu for the trial.
Could you please try the same using the products available after March 12th 2018, of path 15, ascending mode, IW1? So, as reported in my previous screenshot, for instance, one of the dates: 2018_03_25 or 2018_04_06 etc,… of patch 15.
Sorry that these images were not underlined in the screenshot sent.
Thank you very much,
Giulia

Anyhow, I tried again the process, using the subswat and the date Jun_lu successfully did and I have the same problem. So, probably there is not an issue with the downloaded data.
My process is very basic: before Thermal Noise Removal, I simply apply the TopSAR Split selecting the IW1 (for the path 15) and 5 bursts; I then apply the precise orbit (default option), keeping unchecked the ‘Do not fail…’ option.
Later, I go to Radiometric > S1 Thermal Noise Removal and keep all parameters by default. When I press run, the overwrite problem, mentioned and reported in the previous message, appears, which is already something that should not occur… moreover, also if I manually modify the name of the output product, by adding _NR at the end of the name, it does not work, showing the error previously reported. Notably, this problem does not occur if I process images collected in 2017, but only for those after March 2018.
I tried to uninstall and reinstall again SNAP and all updates available but it did not solve the problem.
If you have any idea about what could be the problem, thank you very much for any suggestion!
Giulia

We have tried again using the parameters you provided to the same product (20180330) and still cannot reproduce the problem. Could you check the noise vectors and their contents in the metadata to see if they are complete?

I checked the noise vectors and they seems complete to me, for all IW1,2,3. I send a screenshot.

Interestingly, I found that the process runs without any problem when I avoid the TopSAR Split step. So, if I process all subswats together in the Thermal Noise Removal step, it runs… is there any possible explanation for that?
In any case, it would be definitely better for me to process only the subswat I need (IW2 of the orbit 15), it would be more rapid and less resources consuming… Anyhow, if I do not find any other solution, can I run the TopSAR Split following the Apply Orbit and Thermal Noise Removal steps?
Moreover, the problem of of overwriting the _Orb file remains, but I sow it happens also in the screenshot you, Jun_lu, sent before… Do you have the same ‘overwriting’ issue then?
If you have any other idea about my problem with the Termal Noise Removal, please let me know.
Thank you very much,
Giulia Marchetti

Having much the same problem here - with a similar solution: for me it was due to having fewer than 9 bursts selected during TOPSAR-Split: Thermal Noise Removal Failure in Single Burst - no replies in my thread, and I also posted here: GRD-Border-Noise and Thermal noise removal are not working anymore since March 13. 2018 - #85 by jamesemwheeler
Good luck, and I hope they find a solution, or at least can reproduce this error.

Dear @GiuM ,
have you found out a solution for this? I am experiencing with the same problem (same error message) with data acquired in June 2021 after the last SNAP 8.0 update.
Dear @jun_lu @ABraun @mengdahl any advice for this? Just in addition, the problem with Thermal Noise Removal is only after the TopSAR split step working with SLC data. It doesn’t happen for GRD data.
Thank you in advance.

S Savastano

Personally I don’t think SNAP should allow the operation of Thermal noise removal from SLC images. The estimated thermal noise is a scalar field and should only be removed from detected (scalar) images. @jun_lu