Time Series Analysis Tool - Possible Bug

Hi, I am trying to use the tool with Sentinel-1 time-series and I am running to the same problem with both geometry and pins. I am running SNAP V 6.0.

Hi,
I was trying with pins and Sentinel-1 but there is some problem definitely.
Intensity values of my pins are about 0.03-0.05. But when I click on icon “Show for all pins” graph intensity range is fixed from 0 to 100 and no pin-lines are shown (perhaps there is some line at 0-level but it’s hard to tell). If I move cursor over the image again, single line of the cursor-pixel is shown even if the values are close to other pin values.

Hi,
just want to say that I found out the same problem…
This is something very important that needs absolutely to be fixed in the future!
Regards

I never could reproduce the error, it worked for my every time. This is what i did:

Edit 2021: This is outdated - the Time Series Tool requires single images as inputs at the moment

  1. Make a stack of SAR images (ENVISAT ASAR in my case)

  2. Open the settings of the time-serires tool and select the stack as an input
    grafik

  3. Move the mouse over an opened image (doesn’t need to be RGB) Make sure this is selected grafik


    (values are uncalibrated in my case, therefore amplitude)

  4. Create pins and give colours in the Pin manager

Sometimes it’s needed that you shortly open and close the settings grafik again or that you click on an opened image view so the graph gets updated.

  1. Digitize an area and select grafik to get its mean or standard deviation.

Is SNAP 6.0 is capable to perform PSInSAR analysis using multiple Image data?

No, SNAP can only be used to prepare the images as an input for StaMPS software which can perform PSI. Please have a look here: About the STaMPS category

Hi,
I wanted to create a temporal profile using time series analysis tool. I have tried the same steps as you did. But am not able to get the plot.

try adding all images separately into the time-series tool instead of a stack. This worked for me all times.

Still the same result has obtained for me.Following steps were done:

  1. Added all images seperately in settings page
  2. Moved the cursor point over the image( but the graph was not obtained)
  3. using rectangle drawing tool an area was selected, then clicked “show average ROI”(Still the graph was not plotted)

I got the problem solved…:grinning: It might be due to the update done to the plugins installed.

Can I visualize the temporal profile of selected areas(for which the shapefiles are already created) using the same tool?

1 Like

Hi there,

I have the same problem discussed here. Sometimes the time series works well - graph shows both mouse cursor and pins (I was able to get also ROI only couple of times). But sometimes is just stops working and the only thing I get is mouse cursor. I do not see that this discussion came to a solution, did it?

For S1 images it works better, only occasionally it “stops”, but for S2 images I got only the mouse cursor working, not pins. I know it is designed for S1, but if the mouse cursor works also for S2, why shouldn´t also pins work?

In addition, I have never got it working with a stack, only with separated images.

Thank you.

Hi,

Im having trouble generating the time series chart for a ROI from a shape file from 5 Sentinel-1 SAR images.

I have imported the shape file as a vector. When I selected the ROI simple and Mean, the chart shows up blank and when I export it, it has all the right dates and polygons but the values are all NaaN.

When I put points in the polygons and selected the show for pins button it worked perfectly.

The screenshots below have show the results.

Does anyone know what I am doing wrong?

Hi
we are working with a temporal set of S1 GRD images and have entered the images in a stack as well as separately into the time-series tool. entered individually, we do get a time-line, however, the range is fixed from 0 to 100 so the intensity line is at zero. we have updated all plugins following the success of abhiyaam post on the Feb '19, but still no success. is there a specific plugin needed or any ideas on what might be wrong. we are using SNAP 7.0.3. thanks

press shift to update the y-axis to a reasonable range for the currently selected pixel

thanks, we are unsure of what to press for the y-axis update. we can toggle the x axis range using the cursor position icon on the time series tool but not the y-axis. can you tell us what we are missing?

there is another problem that might be related. when we try to draw an ROI on the image using SNAP draw tool, SNAP freezes and we have to close SNAP with the task manager and restart. reading previous posts, we noticed this occurred in SNAP 6.0. we have SNAP 7.0 installed. is this a continuing problem in SNAP?

sorry, the formatting somehow removed the most important word :sweat_smile:
I updated the post: When you press the [shift] key, the y-axis will be adjusted.

I noticed a similar thing. If you have many rasters and large ROIs, SNAP takes quite a long time and sometimes crashes.

Try to close the time-series tool before digitizing the polygon, then save the product and open the time-series tool again.

great! got it…thanks

a new tutorial on time-series analysis has been published: Time-series analysis with Sentinel-1

2 Likes

I tried to get temporal analysis of Sentinel data (time serie), the time serie tool is always blank. I upload the stack product, i tried to upload the separate products, I create pins, I even create polygone around my AOI but the same problem persists. Do you some hint about how to solve this problem?