Tool executable not found

I have this warning when I open the external tools window
I thought that could be a read rights issue but it is not anything I could find.

I have tried to setup Sen2Cor but it keeps on changing the variable SEN2COR_HOME to
Which does not exist.
I also tried to start from the command line, although the L2A_Process --help seems fine,
I get an error
~/Software/Sen2Cor-2.4.0-Linux64/bin$ L2A_Process --resolution 10 /media/julien/NuDrive/Consulting/Chris/BRB/Ularring/SAT/S2A_MSIL1C_20180211T021341_N0206_R060_T50JML_20180211T063129.SAFE
Traceback (most recent call last):
File “/home/julien/Software/Sen2Cor-2.4.0-Linux64/lib/python2.7/site-packages/sen2cor/”, line 355, in
File “/home/julien/Software/Sen2Cor-2.4.0-Linux64/lib/python2.7/site-packages/sen2cor/”, line 171, in main
File “/home/julien/Software/Sen2Cor-2.4.0-Linux64/lib/python2.7/site-packages/sen2cor/”, line 3415, in setSchemes
self.logger.fatal('wrong identifier for xml structure: ’ + product)
AttributeError: ‘NoneType’ object has no attribute ‘fatal’

My system used to work fine even including snappy but I cannot run Sen2cor at all now. I wonder if all these things could be linked


I have reinstalled everything the standalone sen2cor works now although with bugs.
Still this variable Sen2cor home which comes back to documents/send2cor. In Ubuntu it is Documents with a capital.