TOPSAR-Split inputs differ depending on whether using Graph builder or drop down selection

When I use the graph builder to process S1 IW SLC and add TOPSAR-Split the Processing tab: (1) Subswath does not have any drop-down selection (2) no Polarizations are shown and (3) the Bursts go from 1 to 9999.
In contrast if I select Radar -> Sentinel-1 TOPS -> S1 TOPS Split, I can select IW1, IW2 or IW3, Polarizations and Bursts 1 to 9.
I am not sure what I am doing wrong.

to get feasible parameters in the drop down menu for the creation of a graph, it is good to have one S1 SLC data loaded and use it as input product to create the graph. It is possible that you will see these options only when the graph is fully connected.

I tried this by loading a S1 SLC and when this didn’t work I loaded the image to view. Neither worked. This is SNAP running on Ubuntu. I get the same problem with SNAP running on Windows 10. I attach a screen dump.

This is what I get when I run it from the main menu

As I said, you will not get all options as long as the graph is incomplete. Connect Split with Write and switch tabs to update the available choices.

I think it was a memory problem. I rebooted my computer and the graph works. I need to pay more attention. There was a red message “[NodeId: TOPSAR-Split] GC overhead exceeded” at the bottom of the graph window that I had been overlooking.
Thanks for your assistance. Much appreciated.

thank you for reporting the solution to your problem.