Troubleshooting with S1GRD range doppler terrain correction

I’ve been processing S1GRD data and faced with a problem. I used an external DEM saved in my PC for terrain correction. When I run it, it pops out a window looking as follows:

And when I opened the error message, it looks like this:

How can I solve this troubleshooting and proceed to the next level of my task?


What kind of external DEM was used?
SNAP requires a GeoTiff projected in WGS84. The error message indicates that it is a zip file?

From the help file:

Thank you for the help!

The external DEM is a-90m SRTM-DEM with Geographic (Latitude/Longitude), WGS84, and EPSG:4326. The DEM data is not a zip file. It’s in its Geotiff (.tif) file format.

Best regards,


is there a reason why you use this instead of the auto download options which are based on the same quality (and better)?

I don’t have any reason to use the external DEM.

I’ve tried to use the DEM auto-download option for both the 30m and 90m DEMs; in fact, it was my first option to use the auto-download DEM option. However, when it completes downloading the DEM, it redownloads it indefinitely again and again without completing the output of the terrain-corrected S1 GRD. I don’t know the reason why it became like this.


so the Auto Download does not work and the external DEM does not work either?

Where is your area located?


My study area is located in Tigrai State of Northern Ethiopia, encompassing areas around Aksum and Shire towns.


I’m still wondering why the error message says “error in opening zip file”

Maybe you did not extract the external DEM before selecting it in the RD Terrain Correction module? I use 7zip for such tasks.

It’s not a Zip file. It’s a Tiff file.

Had it been a Zip file, I’d have unzipped it using Winrar or 7zip software to get the Tiff file version of the DEM.


can you please try this one, for a test? DEM

I’ve tried it. It popped out the same error message, as in my first post, after I ran the RDTC module.

Recently, the SNAP development team has released a new SNAP version (SNAP v8.0). I’ll try to download and install this latest version of SNAP. The problem might be fixed in this version.


very strange, I was able to use it as an external dataset. Maybe it is a good idea to re-install snap, yes.