"Unable to download"

Good evening everyone
recently when i download the images of sentinel-2 with the product library it appears “unable to download … etc.” and the download does not end.
can someone help me?

could this be related to the movment of older products to the long term archive? ESA Copernicus data access - Long Term Archive and its drawbacks

Please test with a recent product (acquired during the last 30 days) and check if th error persists.

I have now downloaded the most recent product possible (May 5, 2020) and this has appeared.

This seems to be a different issue. I think the first error you report is caused by the offline status of older products (described in the topic I referred to).
When was the last time the download from within SNAP worked?

About two weeks ago, then without warning I started to face this type of problem.
(In the first case how could I solve the problem?)

Can you please share your log file?
It is the last messages.log file located in the directory indicated in SNAP, under Help -> Show Log Directory.
Thank you in advance.
Best regards,

Good morning
here is the photo attached, thanks.

It’s the content of that file that is needed for exception details. (or parts from it if you can’t attach the entire file)

ah, i’m sorry!
Do I attach the contents of “updater.log2.txt (283.4 KB) updater.log”

No, It’s the messages file that is useful.
Plus, can you please try to rename your download folder in order that it no longer contains spaces (you have a space “immagini sentinel”, you can rename it “immagini_sentinel”), make another search and also specify a mission, I saw you didn’t select any mission).
Then try to download in the renamed folder a new product and see if it works.
Thank you in advance.

I tried with a new folder and specifying the mission, but the result is the same.
messages.log (69.2 KB) (is this?)

Thanks for the log file (yes, that is the right file).
I have searched for the same product, I downloaded it in a folder containing space in its name, and I successfully opened it in SNAP…

Also, in your log file there is only a UI error, and no reason for
“Unable to read C:\Users\leandro\Desktop\immagini_sentinel\S2A_MSIL1C_20200405T100021_N0209_R122_T33TUJ_20200405T111044.zip”

If you try to open the product in SNAP from the download folder, using File -> Open Product, does it work?

The open product and Product Explorer work, the only problem that persists are the downloads unfortunately (unable to read).
If I try to create a new account on scihub and reinstall the app?

I don’t think that this is related with the SciHub account (since the downloaded product can be opened in SNAP without using Product Library).
You can try deleting the .snap directory from your user folder (e.g. C:\Users\leandro\.snap).
Restart SNAP and maybe try downloading somewhere else, not under Desktop directory.

1 Like

The download problem persists.
In this case I downloaded the file anyway even if it tells me that it is unreadble and I tried to open it with open product and I got this.

Try reinstalling SNAP by choosing to delete all user data (they are just SNAP internal files).
The path shown in your error does not seem to be a valid path within SNAP installation directory (C:\Program Files\snap)

As for downloading the latest images(acquiries in the last 30 days) with this way I solved!
But with older images it makes me the initial problem (unable to download).
Unfortunately I am doing a job in which I need the images of 2019, how could I solve in this case?

this brings us back to this point:

I’m not sure if the provision of the archvied products can be triggered from within SNAP.

If I don’t disturb and if it’s not too complicated to explain (I have a basic knowledge of snap)
could you explain me the problem? Because I read the topic you sent me, but I didn’t understand very well (for my poor knowledge aha)

All products older than a certain age are no longer available for direct download from the Copernicus Open Access Hub. They are marked with “offline” and stored in a long-term archive because of capacity reasons and are only provided upon request.
Once you click on “download”, the provision is initated. But I don’t know if this only works in the Copernicus Open Access Hub or if also works from within SNAP.

@mengdahl: Has ordering of offline products been implemented in SNAP?