Unable to install Sen2COR

I’m out of ideas, sorry. You can try running sen2cor from the command line?

@falahfakhri Sir, I tried uninstalling and reinstalling sen2cor by following the exact steps as mentioned in the link you shared.

And this is a slight different error I am getting now.

@ABraun Sir, I really appreciate your help so far. I am very new to using this software. I was planning to do NDSI classification , so for that I am trying to do the atmospheric correction . And this is the error I am getting.
I do not have any programming knowledge and hence I wouldn’t be able to use the command thing.

It is the same error,

The first option now is (must have the folder Level-L2A in your output results, Sen2Cor corrects the Level-L1C product to Level-L2A)

the second option

give a try following the previous post of @ABraun

you don’t need programming languages at all, you simply open your windows command line in the directory where your downloaded data are located (the folder with the full name as extracted must be placed here), as described here:

Afterwards, you enter the command, followed by the resolution and the folder, as described in the link I posted above and sen2cor starts processing the files.
The advantage is that you can exclude that there is a miscommunication between SNAP and the script. If the error persists, there could be something wrong with your data.

I tried to implement sen2cor in my old laptop and I got the following message, might be our colleague @anup_upadhyaya got the same message before executing ,


you have to set it manually here:

I have written a detailled description here: Sen2cor 2.4.0 on SNAP 6.0
Your question refers to point #4 and #5

1 Like

Hi, also remember that every time you try to run Sen2Cor a folder is created in the target location. While this is likely not responsible for your error it might also create problems. It is better to go to the folder where your input data are and delete all the MSIL2A folders.


In my case it is only needed to identify the path of the sen2cor so, as you mentioned from *Tools Manage external Tools, I only defined the path and restart SNAP and now it runs

Do you mean, when the process is done the high lighted folder should be deleted!


only if the process fails, the temporary (and incomplete) product should be deleted before a second try.

The problem has been solved. Thank you so much @ABraun and @falahfakhri for your prompt responses.

good to hear! Can you tell what was the problem?

hello falahfakhri , I face some trouble in following this tutorial. Especially in “Train algorithm” step. where can I get the “Output model” and “output confusion matrix” to run?

Hi @tusar
I’m sorry for this long delay , I hope you get solved your problem,

Which tutorial?