Unable to install Sen2COR

Hello everyone!
I downloaded the Sen2Cor plugin but I am unable to install it. I tried reading the pdf where it says

"Then, change into the directory Sen2Cor-02.05.05-win64 using the windows command line interpreter and call the command “L2A_Process.bat –help”. It shall show:
C:\Users\example_user\AppData\Local\Sen2Cor-02.05.05-win64\L2A_Process.bat --help
usage: L2A_Process.py [-h] [–resolution {10,20,60}] [–sc_only] [–cr_only]
[–refresh] [–GIP_L2A GIP_L2A]
directory "

I am unable to understand what is written above. I am not into programming and stuff. Can someone please help me install step by step.

perhaps it would be easier for you to use directly from SNAP instead of from the command line.

If you have already installed the sen2cor plugin in SNAP, then you have to install the sen2cor tool. You can do it directly from SNAP in Menu-> Tools-> ManageExternal Tools-> Sen2Cor ->Edit and you will find in the tab “Bundled binaries” a button for downloading and installing it automatically.

After these steps, you can go to Menu->Optical->Thematic Land Processing->Sen2Cor and execute it.


@obarrilero Hello. Umm. I am unable to install the Sen2COR plugin yet. How do I install that? Is there an exe file or something?

This is the file I downloaded.
Thank you!

You can install the plugin directly from SNAP: Menu-> Tools -> Plugins -> Available plugins. You have to select the Sen2Cor plugin and click Install.

1 Like

@obarrilero . Did what you said! Thank you !

@obarrilero Hello. Could you please tell me why is this error coming?

followed by this once I click OK and this . Finally once I click OK the same thing starts all over again.


@ABraun would you please to correct this one because I didn’t open a new topic regarding to this topic, I only answered our colleague @anup_upadhyaya ,

@falahfakhri Yes Sir. I think I did. Here’s the screenshot.

Or did I not? How could I possibly know if I installed it right or not?

Thank you.

In case it runs properly, that’s mean it is installed properly ,

Would you please to check up the following tutorial of how to implement sen2cor,

@falahfakhri Thankyou . I followed the steps mentioned in the pdf but I am getting this error. What maybe the possible cause? Could you please help me out.

As input file, choose the *xml file as your input, aftermath to extract your image as below


Navigate and select the xml file as your input,


Let me know if it works

@falahfakhri I did what you mentioned but the error is the same.

Would you please to try up by using other product

By the way would you please to watch this video might be it helps, tell me if it works,

@falahfakhri I am still receiving the same error even after having followed the same steps as mentioned above.
You have been really helpful until now Sir.
I am attaching the screenshot of the error that is popping out.

This is what I selected as you mentioned previously

And this is the error that pops out after hitting the command run.

What could be the reason Sir?

I tried using other product as well.

Did you extract your product properly?

Here is a lot of posts related to your issue, have a look please,

can you try with the “cr only” checked?

@ABraun I tried doing that too, Sir. This is the error that has been generated.new