Sen2cor v2.8

I was trying to process data in SNAP with sen2cor 2.8. Sen2cor has been installed successfully but I can not start to run it. ‘‘I am left with a black console window where nothing happens and an instantly disappearing progress bar.’’ I have tried to set system variables of python.exe again but it still did not work. I was wondering if it is because of my python version 3.6. Should I use python 2? Is the sen2cor under the umbrella of python 3 or above?


1 Like

that should not matter. sen2cor is installed with its own version of python so that all packages are installed at the correct version.
Have you tried running L2A_process from the command line?

this is the way to use the shell for applying sen2cor

L2A_Process.bat --resolution 10 D:\S2

Take a look at this thread (please read all the posts)

Source of the thread

Yes, but I only have run the L2A_process- help in command line to test the installation. It looks that I have installed it successfully as the installation book.

Thanks, I am gonna try it. Hope I can get the corrected images anyway.

that means the configuration could be not correct in SNAP. Can you please show a screenshot of Menu > Tools > Manage External Tools > sen2cor > Edit > System Variables

Here is my current system variables. It is weird because I add variables of PYTHON_BIN and SEN2COR_HOME yesterday, but I can not find them today.

PYTHON_BIN is no longer needed because the python distribution is inside the sen2cor directory.
Pointing to a different Python distribution will probably cause errors because it has different modules installed.

Looks alright though…

I use the variables like above but it still can not run. :cry:

Please take a look at this post, how to apply sen2cor

Source of the post


Source of the post

and this post,

Source of the post

Your demand starts at the 37 minutes time of the video

Hi everyone, I have just solved problem. I can now apply sen2cor to SNAP. I found I can achieve it by change the version into 2.5.5. My data is based on year 2018. So maybe the version 2.8 can not support them. I can process my data now. But I can not load the L2A band data in SNAP. I can only load data like AOT or SCL. I do not know why. If someone know about it, could you please let me know? Many thanks.

Hello everyone.
I’m having problems applying sen2cor 2.8 in SNAP 7.0.
The Sen2cor seems to be installed successfully; I’ve checked the "L2A_Process.bat --help” in the command line as indicated in the installation tutorial and everything seems to be as expected. However I cannot run sen2cor. I already tried to access through “Tools - Manage external tools”, either with Sen2Cor255 and Sen2Cor280 but it doesn’t work…
Do you have any suggestions?

Have you renamed the input product somehow?
What is the full path to the S2 data?

Hi there! Thanks for your feedback.
I didn’t renamed the input product.
The full path of the S2 data is:

I think the problem can be caused by the character Î in your path.

Thanks for the tip! I didn’t notice that I had included the Î character in the path…
Problem solved!
Thank you!

I didn’t notice that I had included a character Î in the path…
Problem solved!