Unable to save or load the metadata


I pre-processed some TanDEM - X data with PolSARpro. Now I would like to have Geocode this data with SNAP. Therefore, I import the pre-processed files in SNAP. I opened separately the original File. If I go to “Tools -> Metadata -> Replace Metadata” I am able to choose the metadata from the original file, but then I get this error message (see picture):

The weird stuff in German mean: “System are not able to find the path”.

In fact there is not a path like this in my .snap directory. What is going wrong there? Where are the metadata from all the products? In SNAP I am able to view the metadata.

Thank you in advanced.


Open the original TSX product and select it for the metadata replacement. I’m not sure why it can’t find the path to an intermediate file it uses to write the metadata.
Instead of using the menu item, try using the ReplaceMetadata operator in the Graph Builder.

Hello Lveci,

thank you for your reply. I tried it the way that you told me. It works with the Graph Builder without an error message, but the replacement of the metadata wouldn’t work anyway (see picture: on top the original TDX metadata and at the bottom the polsarpro binary file after metadata replacement). If I try the terrain correction the error message says something like “The input product should be an SAR product”. Where are the .xml files? I am not able to find the path of the .xml metadata.

Thank you very much!!!


OK!!! I got it. I forgot to add the “write” operation in the Graph Builder. Now it works perfect. Thank you very much