Unable to use sen2cor on a single granule using gpt

Dear all,
I was successfully able to use sen2cor from gpt cmd for S2A_MSIL1C_XXX images. I now want to do the same for S2A_OPER_PRD_MSIL1C_XXX images (products generated before 6th dec, 2016). I could use the command (for eg):
gpt sen2cor.xml E:\test\S2A_OPER_PRD_MSIL1C_PDMC_20160429T215735_R022_V20160429T101028_20160429T101028.SAFE
But since it has multiple granules in it, I would like to choose only the one that I am interested in and process it.

This is what I found on sen2cor user manual:

But if i try to use it as follow on a single granule:
gpt sen2cor.xml E:\test\S2A_OPER_PRD_MSIL1C_PDMC_20160429T215735_R022_V20160429T101028_20160429T101028.SAFE\GRANULE\S2A_OPER_MSI_L1C_TL_SGS__20160429T140042_A004452_T32UQV_N02.01
I get error: No product reader found for file

and if I point to the xml file inside the granule folder as:
gpt sen2cor.xml E:\test\S2A_OPER_PRD_MSIL1C_PDMC_20160429T215735_R022_V20160429T101028_20160429T101028.SAFE\GRANULE\S2A_OPER_MSI_L1C_TL_SGS__20160429T140042_A004452_T32UQV_N02.01\S2A_OPER_MTD_L1C_TL_SGS__20160429T140042_A004452_T32UQV.xml
I get error: No target product set

How can I continue in this case?

I have attached sen2cor.xml file.sen2cor.xml (1.3 KB)

PS: Cross posted. Intially posted on an old topic. Sorry if this is not allowed.

Why not directly use L2A_process instead of gpt?

1 Like

Thanks for your reply. I don’t know how to use it (I am new to SNAP). I’ll give it a try.
I referred to the user guides https://senbox.atlassian.net/wiki/spaces/SNAP/pages/70503053/Processing so chose to use gpt.

Thanks again. I just tried with L2A_process and it is working fine. I should have tried it before instead of sticking with gpt.

good to hear that this is a possible solution for you!

Just one word why this did not work.
Your command line call was missing the parameter were to write the result to.
gpt sen2cor.xml -t E:\test\output\S2A_OPER_MTD_L1C_TL_SGS__20160429T140042_A004452_T32UQV_SEN2COR.dim E:\test\S2A_OPER_PRD_MSIL1C_PDMC_20160429T215735_R022_V20160429T101028_20160429T101028.SAFE\GRANULE\S2A_OPER_MSI_L1C_TL_SGS__20160429T140042_A004452_T32UQV_N02.01\S2A_OPER_MTD_L1C_TL_SGS__20160429T140042_A004452_T32UQV.xml

Thank you @marpet for your reply. I just tried with -t parameter. But I got the same error. Maybe the error is related to source folder naming format. This is the detailed error message that I got.

gpt d:\sen2cor.xml -t d:\S2A_OPER_MTD_L1C_TL_SGS__20160807T153843_A005882_T32UQV_sen2cor.dim D:\S2A_OPER_PRD_MSIL1C_PDMC_20160807T233335_R022_V20160807T101028_20160807T101028.SAFE\GRANULE\S2A_OPER_MSI_L1C_TL_SGS__20160807T153843_A005882_T32UQV_N02.04\S2A_OPER_MTD_L1C_TL_SGS__20160807T153843_A005882_T32UQV.xml
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
Executing processing graph
INFO: org.esa.s2tbx.dataio.s2.ortho.S2OrthoProductReaderPlugIn: Building product reader - EPSG:32632
WARNING: org.esa.s2tbx.dataio.metadata.GenericXmlMetadata: Metadata: the path to element [bandid] does not exist
INFO: org.hsqldb.persist.Logger: dataFileCache open start
Warning: org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not recognized.
Compiler warnings:
  WARNING:  'org.apache.xerces.jaxp.SAXParserImpl: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.'
Compiler warnings:
  WARNING:  'org.apache.xerces.jaxp.SAXParserImpl: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.'
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterOp: Executing tool 'Sen2Cor' with command line: 'C:\Users\Rajan Paudyal\.snap\auxdata\Sen2Cor-02.05.05-win64\L2A_Process.bat D:\S2A_OPER_PRD_MSIL1C_PDMC_20160807T233335_R022_V20160807T101028_20160807T101028.SAFE\GRANULE\S2A_OPER_MSI_L1C_TL_SGS__20160807T153843_A005882_T32UQV_N02.04\S2A_OPER_MTD_L1C_TL_SGS__20160807T153843_A005882_T32UQV.xml --GIP_L2A C:\Users\Rajan Paudyal\documents\sen2cor\L2A-GIPP25-custom.xml'
INFO: org.esa.snap.core.gpf.operators.tooladapter.DefaultOutputConsumer: L1C user product directory must match the following mask: S2?_MSIL1C*.SAFE
INFO: org.esa.snap.core.gpf.operators.tooladapter.DefaultOutputConsumer: but is: GRANULE
INFO: org.esa.snap.core.gpf.operators.tooladapter.DefaultOutputConsumer: Finished tool execution in 1 seconds
WARNING: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterOp: Tool may not have produced an output

Error: [NodeId: Process] Operator 'ToolAdapterOp': No target product set.

the above logs might be the reason and the message “No target product set.” is only a follow up error.

@obarrilero do you know more about it, or maybe @kraftek ?