Unwrapping my product

does anyone knows why am i getting this error?

the error message is quite generic. Some questions

  • did you select VV polarization only in the Split operator?
  • does the interferogram look alright?
  • have you executed the unwrapping successfully? besides the UnwPhase_.hdr there should be a UnwPhase_.img in the working directory.
  • have you selected the product before unwrapping in the 1-ReadPhase tab as reference?
  • did you select the hdr file of the unwrapped product?
  • i selected the two polarizations VH and VV

  • the interferogram looks alright

  • i guess i did the export correctly where i got in a folder with the same name as my input product containing the hdr and img for coherence and phase in two polarizations, the snapu config file and hdr file of unwrapped phase. after the unwrapping many files before and after unwrapping have been created but in another directory. my problem is in the import step.

  • yes i did

  • i choose it from the folder and click on the hdr file

the UnwPhase_*img was not created. Have you tried running snaphu from the command line?

Please have a look at the notes on the use of snaphu in this tutorial: Sentinel-1 TOPS interferometry

how to run it from the command line?

Please see here under “Manual usage instructions”: https://step.esa.int/main/third-party-plugins-2/snaphu/

It’s also described in this video: https://www.youtube.com/watch?v=sH4Uhsgmpak

I still suggest to only work with VV polarization because it largely reduces processing time and avoids errors at later steps.

i think there might be something wrong in this step becuase we i tried to do the unwrapping in the command there was nothing written.
now, i will do a subset of my interferogram for VV polarization.

As I said, running snaphu from the command line is less prone to configuration errors than the snaphu plugin within SNAP. But it is good to reduce the data first.