Updating SNAP6 modules: networking problem

#1

I installed SNAP 6 on Windows 10 and regularly apply updates when SNAP reported its availability.
However with the latest update (e.s. SNAP Desktop Rich Client Platform 6.0.4) it fails.
It reports for example “Networking problem in http://step.esa.int/updatecenter/6.0/snap/ceres-jai-6.0.4.nbm
I’ve checked the proxy configuration (there is no proxy).
In this case I can download it manually, but with the next one “http://step.esa.int/updatecenter/6.0/snap/ceres-core-6.0.4.nbm” if I put it into the browser then it says “The connection to the website was reset. Error Code: INET_E_DOWNLOAD_FAILURE”.

Similarly if I go at http://step.esa.int/updatecenter/6.0/snap/ I can see the list of the *.nbm but still I cannot download some of them.

From previous SNAP update the only change in my PC was an update of Windows. Furthermore my PC is within my company’s network, but IT people says that http: addresses are never blocked and furthermore the step.esa.int was put in the white list of allowed sites. But from outside the company network (e.g. from another PC) it works. Unfortunately I cannot move my working PC outside the company’s network.

Can you help me figuring what can be the reason ?
There is a way to manually download the updates and then make SNAP use them?

Regards,
Giulio

0 Likes

Unable to connect to update center
#2

I had similar issue with installing plugin (Sen2Cor for SNAP - 6).
So changed plugin settings little bit. Here is what worked for me=>
These many not be right settings. Keep note of default settings before changing URL manually.

In ‘Plugins’ window under settings tab three configurations update centers were seen. For ‘SNAP’ I changed URL to
http://step.esa.int/updatecenter/6.0/snap/updates.xml.gz
and
For ‘SNAP Extensions’ to
http://step.esa.int/updatecenter/6.0/snap-extensions/updates.xml.gz

Couldnt find separate URL settings specifically for updates.

0 Likes

#3

Currently they are the actual settings.
What sometimes works is to substitute the http:// with https://

http://step.esa.int/updatecenter/6.0/snap-extensions/s2tbx-s2msi-reader-6.0.2.nbm on my network doesn’t work, while

http://step.esa.int/updatecenter/6.0/snap-extensions/s2tbx-s2msi-reader-6.0.2.nbm, does work.

We opened all the ports and I’ve no firewall, so I don’t know why one works sometimes and vice versa. So to change the settings doesn’t solve the problem !

So my actual solution is to launch the automatic update and every time a .nbm cannot be downloaded then I take it manually - trying both http or https - and install it manually in the plugin manager. Then I launch again the automatic update and so on.
For 6.0.4 it took almost 20 minutes, but at least worked.

However this doesn’t work for updating with nogui (e.g. when building docker containers).

0 Likes

#4

At the end I managed to find the problem: I opened temporarily all the ports on our firewall and the update went smooth.
Now my question is: there is someone to ask what is/are the port(s) to open?

Regards,
Giulio

0 Likes

#5

Actually only simple http requsts are done on port 80. Usually no special porthanlding needs to be done.

0 Likes

#6

In here, someone solved this problem?

0 Likes

#7

Maybe you ask your IT/Network admin. At least the server is working well at the moment. I’ve mnot problem to connect to it. The reason might be your proxy or firewall settings.

0 Likes

#8

Problem solved for me by the way re-install software on different folder (snap_sentinel). in second, deleted all cache of my browser from Windows control panel> Internet options> General tab

0 Likes

#9

The problem was solved with the update of more or less one month ago, that is: suddenly the update worked well. I waited the next one (few days ago) to double check.
However we didn’t change anything on our side.

0 Likes