Usage of RAM and CPU by SNAP software

I have a query regarding the Ram and CPU used by snap software.
I am working on temporal Sentinel 1 GRD data of the large area. When I am doing stacking of imageries in my workstation having 32 GB RAM and operating system window 7, I noticed in the taskbar, that the snap software is using only 12 GB RAM and 3 to 7 % CPU. And also, it took around one day to stack all the ten images. I am not getting why is the snap software not using the full RAM and the CPU as shown in the taskbar.

Kindly help me with this.

1 Like

From Tools tab—>option —>performance, Increase the Cache size to 15000,

Delete these two lines from the in snap




Please take a look at this post and the posts below,

Source of the post

Please take a look at this post,

Source of the post

Thank you, Sir, for your response to my query.
Actually these two lines are not showing in my file. I also reinstalled the snap software. And after putting all the images for stacking, I checked again it is not showing these lines in the file.
#SNAP configuration ‘snap’
#Mon Nov 18 11:07:13 IST 2019

Did you re-apply the process of stacking and checking up the properties have been mentioned in your first post, to find out if they’re changed as well,

Yes, Sir, I reapply the stacking process and i checked in the taskbar, it is showing 12 GB RAM and 2 to 11% CPU used there.

I think the best one here could help you is @marpet Many thanks Marco

Hello Sir,
Kindly help me regarding my query.

if you have 32 GB RAM try to increase the maximum to 24G, for example.

In another topic, a value of 50% of the available RAM has been suggested, this would be 16G in your case: S1 TOPS Coregistration error - Java heap space error?
Please test both configurations to see in the Task Manager if the memory usage increased.

Thank you, Sir, for your reply.
Actually I tried it, only the RAM increased which took approximate 5 hours whereas the CPU showed 3 to 11%. Still, the stacking process is taking more time.
I tried other systems also but the problem remains the same.

is your data located on a local drive or maybe on a network/USB drive with limited reading/writing speed?

Yes, sir, the data is in an external hard drive.

this can be a problem. All your CPU and RAM are worthless if the data transfer between your PC and the drive is too slow. Try moving the data to your local drive (SSD preferably) and run again to see if it changes.

Indeed, I had the same problem and the Windows Task Manager has shown that reading/writing files is where it got stuck.
The processing time got reduced when I changed the target directory to my external HD (with quite high writing speed) while keeping the source files on the local drive.

Thanks for your reply.
Actually, Sir, I copied data to my local hard drive (HD). The processing time reduced now which took 8 hours to complete the stacking process. Now it has used the memory of 27GB and CPU of 3 to 14% but why is it not using CPU properly.

That’s a known issue.
For some processing operation ont all cores are utiliesed. Hopefully, this will be fixed for the next release.

1 Like

Thanks a lot, sir for clarifying my query @ABraun, @marpet