Using DEM for L2A_Process - Error

Hi all. When I want to process image from 1C to 2A using sen2cor L2A_Process, and when I am configure L2A_GIPP.xml to use DEM to dem/srtm folder I get this:

The download of srtm images is good, and when L2A_process start, I get new images for scene that I process:

Then at some moment I get like this in terminal:

And this message is sitting 2 days and nothing happens.

Please, what is the problem?


I get the same error. Process stop and no messages are printed in the terminal.
When processing using NO DEM the correction is performed without errors.

Any ideas?


Hi both. It looks as if multiple instances of the gdal warp are executed in parallel and that this apparently blocks the generation of the DEMs. Can you confirm that you are doing a parallel processing? And if yes, how many processes in parallel?
Can you try with only one processing? Before you do this, remove the temporary files in the dem/srtm directory (these are the ones with the long names). Leave only the images with the name srtm_xx_yy.tif. In the next days I will try to reproduce your problem.

Nevermind. I was trying indipendent processing and nothing happens. Same problem.

help please :slight_smile: I didn’t reply for the first time, so I don’t know did you get a notification.

OK, I will have a check, but I need some more info in ahead: please give me the ID of the product you are working with. I need this because I need to check whether there is something wrong with the generation of the DEMs for this product in special. Does it always occurr or does it randomly occurr, and how many tiles do you process? Thanks for your info.

I can’t find ID of product. Name of scene is:
I am processing entire scene, all granules.
You can see which srtm dem scenes I have, and what L2A_Process created, and than nothing happens:

Answer. Again forgot reply -.- sorry

it’s random.

Then, I again start L2A_Process leaving one created DEM, and then he creates two more dems.

And when i tried to process One Granule it’s the same.

what is completely strange is the mix of the two progress meters of GDAL (the dotted numbers: the should normally go from 0 - 100 - it looks like in your case two gdal processes are started at the same time and they seem to interfere. I never observed this before …

Solution? Some env variables? Versions? Something?

I need to investigate this and then I can give you a concrete answer.

Hi all,

I’m experiencing a similar problem running sen2cor from the command line in Debian testing: everything works fine without the DEM but the process stops with no error if the DEM folder is specified (inside the sen2cor installation folder or not didn’t change anything…). By the way, I don’t see the strange behavior reported by Milutinke that made umwilm think to a conflict between several parallel processes.
I’m processing entire images and it happens every time with images from different locations in Europe, this is what happens

Thanks in advance for your help.
Best regards,


Confirming issue in Ubuntu 16.04. Let me know if there is any info that might be of help.