Using StampsExport with an external dem

Hello @traktor,

Basically I did as you instracted -

  • Unzipped C:\Program Files\snap\s1tbx\modules\org-esa-s1tbx-s1tbx-op-insar. jar
  • Replaced the StampsExportOp.class file with the one you supplied
  • Zipped it again and changed back to *.jar
  • Put it back in its original folder
  • Called gpt.exe from cmd:
    gpt.exe path-to-graph.xml -e -q 10 -x

Still, I get the following error:

Please check your AppData\Roaming\SNAP directory for updated modules

From the path you mentioned I understand that you work with WSL. Unfortunately I was unable to install WSL since it keeps asking for internet connection after unpacking the linux distro using Add-AppxPackage Ubuntu_xxxxxx.appx.

Hello @traktor,

I’ve followed your instructions but my issue still persists - it seems as though it gets stuck right around here. I allowed it to run for about 3 hours and it had not moved, but I’m seeing signs of it ‘working’ when I look at the memory usage on the task manager.

upon opening snap, I get this message popping up:

when I went to the AppData\Roaming\SNAP directory and swapped the ‘StampsExportOp.class’ with the new one (as I did with the one inside the SNAPDIR/s1tbx/modules/org-esa-s1tbx-s1tbx-op-insar.jar), I get this error message instead when I run it:

Although I’m not sure that was supposed to be done. I assumed this is what you meant when you said

[quote=“traktor, post:24, topic:15673, full:true”]
Please check your AppData\Roaming\SNAP directory for updated modules

Is there something that I’ve done wrong? I’m very new to this and have only been following instructions put forward by the RUS Copernicus webinar (HAZA09 : SNAP2StaMPS: Data preparation for StaMPS PSI processing with SNAP). The stamps_export for them seemed to have worked effortlessly.