VV problem

Hi Everyone

I am a Msc student of forestry in Zhejiang University,China. My research direction is application of Sentinel-1A in vegetation cover.
Recently I have faced difficulty regarding SNAP. My problem is I cannot open, process and subset band VV of of GRDH level. All these process can be applied to the VH but do not work for VV. So far I have tried different platforms, many times download the file, and look at the SNAP blog. But I could not find any solution nor answer.

Would you please guide me. I have put the error below this email.

Many thanks



org.esa.snap.framework.gpf.OperatorException: Calibration: java.lang.NullPointerException
at org.esa.snap.gpf.OperatorUtils.catchOperatorException(OperatorUtils.java:412)
at org.esa.s1tbx.calibration.gpf.CalibrationOp.computeTile(CalibrationOp.java:184)
at org.esa.snap.framework.gpf.internal.OperatorImage.computeRect(OperatorImage.java:80)
at javax.media.jai.SourcelessOpImage.computeTile(SourcelessOpImage.java:137)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
Caused: org.esa.snap.framework.gpf.OperatorException: Calibration: java.lang.NullPointerException
at org.esa.snap.framework.gpf.internal.OperatorExecutor$GPFImagingListener.errorOccurred(OperatorExecutor.java:374)
at com.sun.media.jai.util.SunTileScheduler.sendExceptionToListener(SunTileScheduler.java:1646)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:921)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at javax.media.jai.PlanarImage.getData(PlanarImage.java:2085)
at com.bc.ceres.glevel.MultiLevelImage.getData(MultiLevelImage.java:64)
at org.esa.snap.framework.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:412)
at org.esa.snap.framework.gpf.internal.OperatorContext.getSourceTile(OperatorContext.java:398)
at org.esa.snap.framework.gpf.internal.OperatorImage.computeRect(OperatorImage.java:73)
at javax.media.jai.SourcelessOpImage.computeTile(SourcelessOpImage.java:137)
at com.sun.media.jai.util.SunTileScheduler.scheduleTile(SunTileScheduler.java:904)
at javax.media.jai.OpImage.getTile(OpImage.java:1129)
at com.sun.media.jai.util.RequestJob.compute(SunTileScheduler.java:247)
[catch] at com.sun.media.jai.util.WorkerThread.run(SunTileScheduler.java:468)

how did you try to open it?

Hi I open GRDH zipfile in snap. There is not problem with VH but I cannot handle VV.

This looks like a implementation problem.
Which version are you using? Have you installed the module updates.?

Maybe @junlu can have a look at it.

I’ve merged the conversion into this thread. No need to have two threads.

Many thanks for your concern. Regarding your questions, SNAP 5.0. , Yes Updated.

Hi. Was this solved? I have the same problem with three GRD images. When I subset, VH is fine but VV is empty.

A workaround is to display a RGB with Amplitud VH, VV and VH when doing the subset. If I display only one band, only that band is exported eventhough all bands are selected in the bands tab

I do apology to reply so late. I was out for quite long time. Thanks to inform me. It did not work. I used another way which is deleting one band. Then I subset the kept band. It works very fast.