What is the native OLCI level-1 FR projection

Dear Forum members,

I am trying to understand if there is any CRS assigned to OLCI level-1 full resolution product?

In other words, do I have to do reprojection before the usage? Any reprojections inevitably changes the original data, right?

I operate at pixel level thus it is better to avoid data transformations. Is Sentinel-3 a bad choice for per-pixel (point) monitoring?


Have a look at the S3 OLCI User Guide.

Optical sensors provide data in an array where the rows are “scan lines”. Standard processing workflows do geolocation and calibration, then atmospheric correction and generation of “level-2” geophysical products. If you are monitoring a point location you can extract level-2 values for that location (or a small neighbourhood of the location) using SNAP’s Pixel Extraction. There are tools to automate this if you have many images to process (e.g., monitoring over time).

Yes, the data is unprojected. The image geometry is more or less as it has been measured by the sensor.
If you are working on a pixel basis there is now need to reproject the data. This is more important if you are looking at regions.

When you select nearest-neighbour resampling for the reprojection the values are not changed.

Thank you Marco (@marpet) and George (@gnwiii) , now it is much more clear to me.

A follow up question is how to properly reproject to UTM. I may start a new thread if it seems more appropriate. To begin with, I found a lot of questions about OLCI reprojection and problems with per-pixel geocoding mode, but I did not find my case there.

The case is that the image gets truncated after reprojection to UTM 31N zone.

I presume the image gets truncated.
I was able to reproject, copying crs from the product I had (“What I want”, which is UTM 31N as well), but the desired product will not be with me all the time. Setting the desired file resolution, width and height did not help.

Is it a known issue of truncating?
Shall I parametrize the Reprojection operator differently? (Graph processing command does not change with crs specified as EPSG 32631 or copied from the product).

Do you have all updates installed? This sounds like an issue which is actually solved.

It says all updates installed.
SNAP and S3TBX versions 7.0.4
Java SE runtime environment 1.8.0_202-b08.1

Oh, I see, today the new version 8.0 was released. I will try, though, I wanted to check back-compatibility.

Yes, it works for SNAP 8.0.

However, @marpet did you mean that the issue had been solved in some 7.0.x version already?

I thought so. Maybe I was wrong and mixed things up.

All right, thank you! Solved.