What is wrong with version 3.0.0

Hi! I am new in this, so maybe I missed something, but is it possible to be something wrong with the new ( 3.0.0 (31.03.2016 8:00)) version of SNAP?
I tried to learn the basics from this site, but I had some problem also with the first lessons… I tried to calibrate my image, but it crashed 3 times… I tried this on windows 8.1, 64 bit, intel i7, with 8 gb ddr3 ram, so I think this is ok for this program, but, I don’t know how can I resolve this.

Many thanks!


you are right, your computer seems to be sufficient.
Can you tell a bit more about the crash. What kind of error do you get?

Thank’s for answering me!

Many times crashed with message “Cannot construct DataBuffer”, type:“Operator Exception”; Once crashed with some java stack error… ; Once crashed the all program and I saw the created file, and it wasn’t ok… I had just some rows from the created image… Once completed, but the created file also had the same problems…

So any idea?

“Cannot construct DataBuffer” is a quiet common problem when processing S1 data (e.g. Error when calibrating Sentinel 1 data “cannot construct data buffer”).
You can try the performance tool. You find it at Tools / Options in the menu.
Choose one of the operators (Calibration is probably not a bad choice) and let it compute the best settings.

Hi Marpet, do you know roughly how long this should take? It has so far reached 14% progress and I began around 6 hours ago! Thanks

I have also the same problem. For me this don’t want to move from 35%…

If it takes so long then there is probably one of the configurations which is not performing well.
Another options is to enable the cache for Sentinel-1 reader. You can find it in the S1TBX tab in the Options dialog.
Maybe @lveci can say something on how to find the best configuration.

I can’t get in touch with @lveci, I wrote a mail too, but nothing.
But I also tried many options in the calibration menu what You said. And I make once probably but, after then I tried again from radiometric calibrate and the error was the same…

Could you help me, what can I do then, or how to contact with @lveci, or any idea, how can I start if this not work?

Processing Sentinel-1 products can use a lot of memory because the Tiff reader we use puts everything into memory. If you have a number of swaths and dual polarizations this can be big somethings. If you are working with S1 SLC products, you can use the TOPS Split operator to select a single subswath and polarization. You can also use the file caching in Tools -> Options and S1TBX tab.

Also, please check that you don’t have a lot of other applications using your memory as well.