When open sen2 data,diaplay error,or cannot display

I am currently facing some Problems in the s2tbx preprocessing. After I install the snap,and open the product I have download,problem occurs,

I don’t know why it can not display,It seems not like this in the help contents the snap provides,could anybody tell me how can I deal with this problem?THX.
In addition,when I open the JP2 file directly,not to open the MTD_MSIL1C.xml,it can display normally like this:


what is your operative system? Which version of SNAP are you using?

thanks for reply,
wiindows 10,SNAP 5.0

There are somes issues that could be related with your problem:

  • Path too long: this was solved in a previous version of SNAP, but the fix requires that the short path is enabled in Windows. (Can not open S2 xml datafile). If this is the cause of your problem, if you copy your product to a shorter path, it should work.
  • Some users have had problems when unzipping the product, they fix them by using 7z (Can't open S2A L1C data xml)

Please, if the above solutions do not work, could you tell me what is the product to download it and test?

But I have tried the two ways,it doesn’t work,
this is the product I download,


I have just downloaded the product and it seems that there is a problem with it. In SNAP, the Sentinel-2 reader uses the quantification value of the metadata to transform the digital number to reflectance (Reflectance = DN/quantificationValue), but in this product, the metadata is wrong and the quantification value is set to 0:

It should be something like:

When you open the JP2 images, the metadata is not used (because it is not open as a Sentinel2 product) and the pixel values displayed in SNAP are directly the digital number without any transformation. If you divide it by 10000 you will get the reflectances.

1 Like

Thanks,It do work!
By the way,this problem is common to see or just a incident?Will the product of the area that I select always have this problem?

Just an incident, not common to see.
If you want, you could modify manually the MTD_MSIL1C.xml: change the quantification value by 10000 and probably it works.

Hello @serhh ,

I’ll undertake further investigation of this. As Omar @obarrilero says, this is not common.



S2 MPC Operations Manager


roger that,Thanks!


Well, we’re still looking… Our investigation confirms this is an isolated case, but our colleagues who look after the processor suggest that the error stems from a failure in the function that deals with filling these fields (we also noted that the SOLAR_IRRADIANCE values were set to 0), in that it did not run properly.

A ‘one off’ reprocessing of the affected Datastrip did not reproduce the issue, so the next step is to reprocess the Datastrip again in the Core Ground Segment, to see if we can replicate the issue there.

This whole issue has set me to wondering what SNAP need as a minimum to open a product. Questions, questions… :slight_smile:



S2 MPC Operations Manager

hello @serhh… I just read a comments saying your problem might be associated with a path too long issue… If that’s the case then I have a great solution for you. Try using the LONG PATH TOOL. This will help you solve any kinds of problems concerning path too long issues. I have tried this one and this is proven and tested by many users.