Windows 10: SNAP is not installed properly

I’m new to SNAP and just installed it today. The installation seem to have worked well, at least without any errors. But after the installation, there is no program file for snap, where I saved it to during installation. I can just use it as long as it is opened after the installation. Furthermore all new files I create and save in SNAP cannot be found manually afterwards in the specific folders. I’m using Windows 10 64bit. Java is updated, as far as this might be necessary.
Thanks a lot,

can you please check the installation directory? It should look something like this:


Inside the bin folder, there is snap64.exe which launches the program.


I’m not quite sure what you mean with “files cannot be found manually”, maybe you can specify this a bit.

I installed snap to the directory C:/program files/ but it can’t be found there. There is just no installation directory for snap. I even tried to adress it via cmd but that wasn’t possible either. As well no desktop icon was created though the box was ticked during installation. I tried to install it again several times and on another laptop but had the same problem (the other laptop has pretty similar settings). With every re-installation I was told that snap is already installed on this computer.
To “files cannot be found manually”: All output I produced and exported (e.g. as tiff) was saved in specific folders, but the files can only be found and adressed via snap, not after closing snap. The folders then are shown as empty. I tried to address those files via cmd as well, but without success. My memory is partitoned, I read that this can yield problems sometimes, but I don’t now why this should be the case…

Were the missing files saved to your Desktop? You could be seeing a race condition in Windows Update.

If your problem isn’t the update bug, you need to provide more details. Do have administrative rights on the system? Precisely which Java version are you using (you need an Oracle Java 1.8 runtime)? There are many editions of Windows 10, which are you using? Are you using a personal system or does it use a “managed configuration” (some student labs are configured to restore each computer to a base configuration after use, which could explain your problem)?

1 Like

I’m using Windows 10 Home 1903 (Build 18362.900). The files indeed were saved to a folder on the desktop, but that doesn’t explain why there’s not even an installation directory (which was not on the desktop but C:\program files). I use the Java Version 8 (Update 251)(Build 1.8.0_251-b08) which I’ve recently installed. It’s my personal laptop so I’ve got full administrative rights.

I use the same Java version (but Win 10 Pro) on my personal laptop.

Remote sensing workloads can be hard on disks. Keeping lots of free space (I try to keep 80G free on a 250G SSD) helps minimize wear. It would be a good idea to run the filesystem check, and then look for the missing files in the locations indicated for the race condition bug. You should also check the health of your drive, using, for example, smartmontools or a utility from the drive manufacturer.

Thanks a lot, I’m gonna try this.

So I checked all recommended things: there’s enough space on disk, I did a filesystem check and afterwards still no files were in the directory. I don’t have any issues with any other software except snap. I can easily save files everywhere (Desktop etc.). I restartet the computer and tried to re-install it but still it says that it is already installed and even shows me the installation directory. But if I look there for snap, there’s nothing.
It is strange that I got the same problem on the other laptop and heard of some friends who had the same issue last year…

I just installed it on a USB drive which worked perfectly fine…anyway, thanks a lot guys

Okay, it worked on both of my computers when installed not in C:\program files\ but somewhere else. Thanks a lot for your efforts.

1 Like

Glad you got SNAP working. Still, it would be nice to understand what causes the initial

A filesystem check may restore files to a hidden folder, sometimes in the root directory (e.g., “C:”), so you need to change explorer to show hidden files.

When multiple systems have the problem it probably isn’t a hardware issue, so we need to look for the rare configuration detail that is common to the systems exhibiting the problem. The prime suspect is anti-virus (AV). In the distant past I had problems with AV software that attempted to scan large remote-sensing data files and was “giving up, taking too much time” then moving the files to a quarantine directory.