Work with data S3A_SL_2_LST in snap


#1

Hello!
I work with data S3A_SL_2_LST in snap programe. While I subset this data I have mistake.
May be you want me with this problem ?
mistake


#2

Can you take a screenshot of the arguments that you have entered in the Subset window?


#3

Hi

I have now tried the same and experienced same issue. Which I have confirmed on multiple computers.

File:
S3A_SL_2_LST____20180825T183051_20180825T201150_20180827T014020_6059_035_070______LN2_O_NT_003

When I zoom in, such that the vertical border of the image is not visible and then attempt to perform
“Right click” ->“Spatial Subset from View”,

I get following error:

java.lang.NegativeArraySizeException
at org.esa.snap.core.datamodel.TiePointGrid.createSubset(TiePointGrid.java:1016)
at org.esa.snap.core.dataio.ProductSubsetBuilder.addTiePointGridsToProduct(ProductSubsetBuilder.java:644)

When I zoom in just so that the both vertical image borders are visible the operation can be completed.

Am I missing something or is this a bug?


#4

That’s strange.

it tried it with the same product and it works for me.


Do you have the latest updates (Help / Check for updates)?


#6

I can also get the parameter window. Can you get a subset after clicking ok?


Using SubsetOp.getTargetProduct() to clip S3 SLSTR LST data
Tutorials for Sentinel 3 data with snappy
#7

Ah, now I got it. I thought it happens already when the window opens.
I’ve created an issue for it: SIIITBX-192
I’ll have a look and see if it can be fixed easily. But I can’t promise that a fix will be released soon.


#8

Thank you very much.


#9

I had a look at this. It is not only a problem of SNAP. There is information missing in the LST data which allows positioning the tie-points correctly in relation to the scene image data.
I’m in contact with ESA. Let’s see what the outcome will be.


#10

Just to leave a reply on this.
It has been solved with the newest SNAP update which I downloaded on 18 December 2018 :slight_smile: