Workflow between SNAP and StaMPS

please help me . how did you installed matlab R2018a for linux in UbuntuWSL.I have ubuntu18.04 in wsl2

Please use the appropriate place to discuss installing Matlab in WSL. The Matlab
forum has a much larger community than ESA STEP, so you are more likely to get good advice there.
Note that many of the problems stem from lack of familiarity with linux. If you are not familiar with linux, you may need to study linux in order to understand the Matlab Forum answers.

1 Like

i just running matlab in WSL from the INSAR_master_data folder. It seems mt_prep_snap works well. So i open matlab from this directory and running “stamps(1,8)”. The first step was without errors. The second has this error:

Index in position 1 is invalid. Array indices must be positive integers or logical

Error in ps_est_gamma_quick (line 221)

Error in stamps (line 326)

Does anyone faced the same error.

Thanks, for reading.

Just type getparm() command in matlab then send the screenshot

this is what matlab prints:

Created: ‘06-Jul-2022’
clap_alpha: 1
clap_beta: 0.3000
clap_low_pass_wavelength: 800
clap_win: 32
density_rand: 20
drop_ifg_index: []
filter_grid_size: 50
filter_weighting: ‘P-square’
gamma_change_convergence: 0.0050
gamma_max_iterations: 3
gamma_stdev_reject: 0
heading: 349.6473
insar_processor: ‘snap’
lambda: 0.0555
lonlat_offset: [0 0]
max_topo_err: 20
merge_resample_size: 0
merge_standard_dev: Inf
n_cores: 1
percent_rand: 20
platform: ‘SENTINEL-1B’
plot_color_scheme: ‘inflation’
plot_dem_posting: 90
plot_pixels_scatterer: 3
plot_scatterer_size: 120
quick_est_gamma_flag: ‘y’
ref_centre_lonlat: [0 0]
ref_lat: [-Inf Inf]
ref_lon: [-Inf Inf]
ref_radius: Inf
ref_velocity: 0
scla_deramp: ‘n’
scla_drop_index: []
scla_method: ‘L2’
scn_deramp_ifg: []
scn_kriging_flag: ‘n’
scn_time_win: 365
scn_wavelength: 100
select_method: ‘DENSITY’
select_reest_gamma_flag: ‘y’
shade_rel_angle: [90 45]
slc_osf: 1
small_baseline_flag: ‘n’
subtr_tropo: ‘n’
tropo_method: ‘a_l’
unwrap_alpha: 8
unwrap_gold_alpha: 0.8000
unwrap_gold_n_win: 32
unwrap_grid_size: 200
unwrap_hold_good_values: ‘n’
unwrap_la_error_flag: ‘y’
unwrap_method: ‘3D’
unwrap_patch_phase: ‘n’
unwrap_prefilter_flag: ‘y’
unwrap_spatial_cost_func_flag: ‘n’
unwrap_time_win: 730
weed_max_noise: Inf
weed_neighbours: ‘n’
weed_standard_dev: 1
weed_time_win: 730
weed_zero_elevation: ‘n’

i’m facing the same problem when i run the first step;
can you please show me how i can remove those patches from the patch.list?


Hello Gijs,

I am facing the same problem. How did you solve it?


Hi everyone,

I have been working on the steps described in the RUS Copernicous training guide via Virtualbox and with Ubuntu 18.04 LTS operating system. But I had this problem while executing the first step of Stamps,
stamps(1, 1). As shown below.

Error using fopen
Invalid filename.

Error in readparm (line 19)

Error in ps_load_initial_gamma (line 77)

Error in stamps (line 264)

I’m using Stamps version 4.1b and Snaphu V1.4.2.

I would be very grateful if you could help me to fix it.

Have you completed the mt_prep_snap step successfully?

I have adjusted the coreg_ifg_computation_subset.xml graph in order to include coherence maps to be created were created alongside with the Master-slave coregistration and interferogram generation step. Is it possible to use ps_plot command in matlab to plot the series coherence maps the same way we plot the interferograms?

Hello everyone,
i runned PSInSAR method through SNAP + STAMPS workflow using Sentinel 1 products. Now i’m tryng to do the same with CSK images. I read someting in the forum about it, however i can’t face some issues with Stampsexport in SNAP.

Exactly, wich steps and in wich order must be done in SNAP to generate properly the 4 directories (dem,diff0,geo and rslc)?

Thanks for reading.
My best,

Mr. Braun! would you recommend me a literature to properly understand the meaning of these terms
Spatially correlated DEM error
Spatially uncorrelated DEM error
Phase ramp error
Master atmosphere error.
I would really appreciate it because i am struggling to understand Hooper’s paper when he explains how to to correct those errors

you can check his dissertation where he explains some more details:

Otherwise - Hanssen 2001 is always a great source: Radar Interferometry: Data Interpretation and Error Analysis | SpringerLink (not open access)

1 Like

anyone knows the meaning of "master_master_flag = ‘0’ " in stamps(1,1)

where others says " ans = ‘0’ " Error in StaMPS patch merging (Step 5)
enviroment:snap9 ,stamps4.1b,ubuntu 18.04a,

Good evening. Please tell me, I’m trying to export to PS. But my workflow has been going on for several days and it shows 8% all the time.
My computer has 32gb of ram and I’m running on an SSD. I tried to run it again, but again 8% and it’s been like this for a week and it doesn’t show any errors. I would be very grateful for your advice.

close snap and restart it ,and rerun export

Hello, i meet the same problem, have you solve it? looking forward to your advice.

Hello ABaun,

I tried to make Psinsar using the snap2Stemp workflow. Following the steps mentioned in the manual, I got to the StaMPS export step, and as a result, a project folder contains the final output structure in four folders: rslc, diff0, geo, and dem.
Later, I installed Stamps, in order to run mt_prep_snap.
I know that I have to make some modifications to the configuration.
My question is: which lines should I modify within StaMPS.CONFIG.bash?

Thanks in advance.
Best regards


I seem to have the same issue. How did you end up resolving the Window’s matlab issue to get past the permission denied error here?

Thanks for the help!