Workflow between SNAP and StaMPS

When running the Installer on Linux, I see the below in terminal:

Preparing installation files …

Installing …


the installer does not launch and MATLAB is not installed.
root@DESKTOP-SMROJT0:/mnt/d/R2018a# ls
activate.ini install licenses ui
archives installer_input.txt patents.txt version.txt
bin install_guide.pdf readme.txt
etc java sys
help license_agreement.txt trademarks.txt
root@DESKTOP-SMROJT0:/mnt/d/R2018a# sudo ./install
Preparing installation files …
Installing …
I tried using the suggested solution from mathworks but it didn’t work:
oot@DESKTOP-SMROJT0:/mnt/d/R2018a# ls
activate.ini install licenses ui
archives install_guide.pdf patents.txt version.txt
bin installer_input.txt readme.txt
etc java sys
help license_agreement.txt trademarks.txt
root@DESKTOP-SMROJT0:/mnt/d/R2018a# sudo chmod -R 777 matlab_R2018a_glnxa64
chmod: cannot access ‘matlab_R2018a_glnxa64’: No such file or directory
please help وMy work and results are stalled because of that
thank you in advance

Some large organizations provide Matlab support internally and will know about issues with the organization’s Windows configuration… If that is not your case, you should continue with Mathworks support.

We had some discussions on this here:


Ty so much

I share this post here, in case someone could help me solve the problem in the step 8 of StaMPS

Error after interferogram generation
If getting following linear strips in interferograms, can someone please suggest the cause for this and solution to resolve this
@ABraun if you can suggest something

hello, out of my curiousity, i want to ask something,
so apparently i had been done interferometry analysis using PS-InSAR at my region of study, it has a good correlation with geodetic measurement except at certain part of area, where the result of PS-inSAR are way lower than geodetic measurement,
field observation shows that in that part of area, people and local government regularly rising the land height using soils (brought from another area), to make the region higher so it wont get flooded by sea water, it is certain that this area are experiencing land subsidence, many buildings are abandoned, and becoming lower than the ground,
my question is : is it possible that this case make the interferometry analysis got under-estimation result (compared to geodetic measurement) in this area? i know that PS are mainly come from buildings, but is it has relation to spatial resolution of the sattelite?
thank you

please help me . how did you installed matlab R2018a for linux in UbuntuWSL.I have ubuntu18.04 in wsl2

Please use the appropriate place to discuss installing Matlab in WSL. The Matlab
forum has a much larger community than ESA STEP, so you are more likely to get good advice there.
Note that many of the problems stem from lack of familiarity with linux. If you are not familiar with linux, you may need to study linux in order to understand the Matlab Forum answers.

1 Like

i just running matlab in WSL from the INSAR_master_data folder. It seems mt_prep_snap works well. So i open matlab from this directory and running “stamps(1,8)”. The first step was without errors. The second has this error:

Index in position 1 is invalid. Array indices must be positive integers or logical

Error in ps_est_gamma_quick (line 221)

Error in stamps (line 326)

Does anyone faced the same error.

Thanks, for reading.

Just type getparm() command in matlab then send the screenshot

this is what matlab prints:

Created: ‘06-Jul-2022’
clap_alpha: 1
clap_beta: 0.3000
clap_low_pass_wavelength: 800
clap_win: 32
density_rand: 20
drop_ifg_index: []
filter_grid_size: 50
filter_weighting: ‘P-square’
gamma_change_convergence: 0.0050
gamma_max_iterations: 3
gamma_stdev_reject: 0
heading: 349.6473
insar_processor: ‘snap’
lambda: 0.0555
lonlat_offset: [0 0]
max_topo_err: 20
merge_resample_size: 0
merge_standard_dev: Inf
n_cores: 1
percent_rand: 20
platform: ‘SENTINEL-1B’
plot_color_scheme: ‘inflation’
plot_dem_posting: 90
plot_pixels_scatterer: 3
plot_scatterer_size: 120
quick_est_gamma_flag: ‘y’
ref_centre_lonlat: [0 0]
ref_lat: [-Inf Inf]
ref_lon: [-Inf Inf]
ref_radius: Inf
ref_velocity: 0
scla_deramp: ‘n’
scla_drop_index: []
scla_method: ‘L2’
scn_deramp_ifg: []
scn_kriging_flag: ‘n’
scn_time_win: 365
scn_wavelength: 100
select_method: ‘DENSITY’
select_reest_gamma_flag: ‘y’
shade_rel_angle: [90 45]
slc_osf: 1
small_baseline_flag: ‘n’
subtr_tropo: ‘n’
tropo_method: ‘a_l’
unwrap_alpha: 8
unwrap_gold_alpha: 0.8000
unwrap_gold_n_win: 32
unwrap_grid_size: 200
unwrap_hold_good_values: ‘n’
unwrap_la_error_flag: ‘y’
unwrap_method: ‘3D’
unwrap_patch_phase: ‘n’
unwrap_prefilter_flag: ‘y’
unwrap_spatial_cost_func_flag: ‘n’
unwrap_time_win: 730
weed_max_noise: Inf
weed_neighbours: ‘n’
weed_standard_dev: 1
weed_time_win: 730
weed_zero_elevation: ‘n’

i’m facing the same problem when i run the first step;
can you please show me how i can remove those patches from the patch.list?


Hello Gijs,

I am facing the same problem. How did you solve it?


Hi everyone,

I have been working on the steps described in the RUS Copernicous training guide via Virtualbox and with Ubuntu 18.04 LTS operating system. But I had this problem while executing the first step of Stamps,
stamps(1, 1). As shown below.

Error using fopen
Invalid filename.

Error in readparm (line 19)

Error in ps_load_initial_gamma (line 77)

Error in stamps (line 264)

I’m using Stamps version 4.1b and Snaphu V1.4.2.

I would be very grateful if you could help me to fix it.

Have you completed the mt_prep_snap step successfully?

I have adjusted the coreg_ifg_computation_subset.xml graph in order to include coherence maps to be created were created alongside with the Master-slave coregistration and interferogram generation step. Is it possible to use ps_plot command in matlab to plot the series coherence maps the same way we plot the interferograms?

Hello everyone,
i runned PSInSAR method through SNAP + STAMPS workflow using Sentinel 1 products. Now i’m tryng to do the same with CSK images. I read someting in the forum about it, however i can’t face some issues with Stampsexport in SNAP.

Exactly, wich steps and in wich order must be done in SNAP to generate properly the 4 directories (dem,diff0,geo and rslc)?

Thanks for reading.
My best,

Mr. Braun! would you recommend me a literature to properly understand the meaning of these terms
Spatially correlated DEM error
Spatially uncorrelated DEM error
Phase ramp error
Master atmosphere error.
I would really appreciate it because i am struggling to understand Hooper’s paper when he explains how to to correct those errors