Workflow between SNAP and StaMPS

Hi all,
First thanks for all the advice, this forum is so helpful!
In SNAP I work with Windows (for StaMPS I gonna use Linux).
I created a stack from 14 SLC after split, and apply orbit. This stack was debursted and then a subset defined. The ifgs prepared from this, then topo phase removed and the elevation band added. The two stack I would like to export to StaMPS is in the screenshot. So I got this error what a couple of other users. I tried most of the tips have been written in this forum but the same error always.
Any further idea will be appreciated!

I solved, thanks

Regarding the lat and lon export. Is it ok if I have and 20151202.lon files in geo directory after StaMPS export? Is it necessary to rename them? Or should I add the files with the ENVI or Gamma export?

dear ledotimea, could you please tell me how you loved the problem? Thanks

Dear @Christina,

I had both VV and VH data in stacks so i deleted the VH and saved as another file after this I could successfully export the two stacks. Hope this will help in your case as well!

Hi @Christina
just check this manual created by our good friend @thho

It has all the instruction you need, and I suggest you use ubuntu/debian linux cause it will run more smoothly without error headaches if you try to perform the process on windows.

cheerio, good luck

Hi @daniel_bona,
thanks, yes it works with this method.

Hi, Can I ask about SARscape new version limition in ps analysing, I,m using it and everything proceed good, so why every one go forward to StaMPS !!?

I guess because it is free and can be modified by anyone who understands Matlab language.

@ABraun how to fix this problem ? There are some errors when I doing steps 6 in StaMPS

Dear Katherine
I want to know if we have negative heading , it sholud be converted into positive.

Hi everybody,

In the parm file in ‘‘rslc’’ folder created by SNAP, the heading is 189.43° (or nearly -175° counterclockwise), but in the metadata of the Sentinel-1 the heading is -165° (or nearly 200° clockwise). Does anyone know what could be the cause of 10-degree discrepancy?


Did you figure out a solution or work around to the ‘indices must be…’ error you encountered in step 6 you could share? I’m having the same problem.

Thank you.

Dear @twburns
I deleted .lat and .lon generated from TopoPhaseRemoval and replaced it by creating lon and lat from _stack_deburst result.
So before I delete I have 2 .lat files (.lat and .lat.par) and 2 .lon files (.lon and .lon.par) and after I delete and change them, I have 1 .lat file ( and 1 .lon file (master_date.lon).
I hope this will help you and others

Dear all,

You may be interested in using the snap2stamps package.

Have a look at this thread: Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow



the same problem here

Hi @annamaria I have the files in their respective folders in STAMPS directory. But I can´t run STaMPs as the manual says. There’s a trick for this? (I have modified the Mt_prep_gamma and the config.bash files in order to prepare them for matlab)
Thanks in advance

Hi SAR colleagues

I have done a 34 SLC images stack using the algortithm proposed in the html SNAP to StaMPs manual. I’ve sorted many problems just reading this great thread (my first Linux experience,and in Azure, for worst), but I’m stucked now in the launch of StaMPs. I have all the files properly saved in their directories, but I’m still confused with. According the manual, you have to run StaMPs from terminal, and according to simple algorithm posted by @katherine, you coul do it from matlab.
Please, any help will be appreciated.
Thanks and regards

I just ran mt_prep_gamma and it throws the next error
pmatuser@DataScienceSAR3:~/StaMPS_v3.3b1$ mt_prep_gamma snap 20171212 /media/datadrive/SAR/PSI_SBAS/SANTIAGO/INSAR_master_date/ 0.4
mt_prep_gamma Andy Hooper, December 2012

Amplitude Dispersion Threshold: /media/datadrive/SAR/PSI_SBAS/SANTIAGO/INSAR_master_date/
Processing 0.4 patch(es) in range and 1 in azimuth

20171212/*slc/snap.*slc.par: No such file or directory.
20171212/*slc/snap.*slc.par: No such file or directory.
ls: cannot access ‘20171212/slc/.*slc’: No such file or directory
cat: /home/pmatuser/StaMPS_v3.3b1/calamp.out: No such file or directory
@: Badly formed number.

If I list the archives in the rslc folder, I can see the 20171212.rslc and 20171212.rslc.par files
pmatuser@DataScienceSAR3:/media/datadrive/SAR/PSI_SBAS/SANTIAGO/INSAR_master_date/rslc$ ls
20170522.rslc 20170826.rslc.par 20171212.rslc 20180318.rslc.par
20170522.rslc.par 20170907.rslc 20171212.rslc.par 20180330.rslc
20170603.rslc 20170907.rslc.par 20171224.rslc 20180330.rslc.par
20170603.rslc.par 20170919.rslc 20171224.rslc.par 20180411.rslc
20170615.rslc 20170919.rslc.par 20180105.rslc 20180411.rslc.par
20170615.rslc.par 20171001.rslc 20180105.rslc.par 20180423.rslc
20170627.rslc 20171001.rslc.par 20180117.rslc 20180423.rslc.par
20170627.rslc.par 20171013.rslc 20180117.rslc.par 20180505.rslc
20170709.rslc 20171013.rslc.par 20180129.rslc 20180505.rslc.par
20170709.rslc.par 20171025.rslc 20180129.rslc.par 20180517.rslc
20170721.rslc 20171025.rslc.par 20180210.rslc 20180517.rslc.par
20170721.rslc.par 20171106.rslc 20180210.rslc.par 20180529.rslc
20170802.rslc 20171106.rslc.par 20180222.rslc 20180529.rslc.par
20170802.rslc.par 20171118.rslc 20180222.rslc.par 20180610.rslc
20170814.rslc 20171118.rslc.par 20180306.rslc 20180610.rslc.par
20170814.rslc.par 20171130.rslc 20180306.rslc.par 20180622.rslc
20170826.rslc 20171130.rslc.par 20180318.rslc 20180622.rslc.par

Dear @CarlosSierralta,
When you said… “I have modified the Mt_prep_gamma” , how had you done it exactly?

As I have already replied yesterday in this thread: Snap2stamps package: a free tool to automate the SNAP-StaMPS Workflow , you only need to modify the s by an f on the lines there mentioned.
Let me know and you still have the problem after trying that, I will share with you my modified script.

Regarding matlab, it can be run via GUI or via command line if you run it with the -nodesktop option.

I hope that this helps!