Workflow between SNAP and StaMPS

I want to detect deformation in mine pit. so I work on 31 SLC sentinel-1A from 2014 to 2016 an processed them in SNAP 6 based on workflow that I found in this topic (and forum) for PSI method. I took export for StaMPS and follow steps in manual . After step 5 in StaMPS (using ps_plot(‘w’)) , I think there is a problem with the results. it seems the number of PS is low and noise is high . is it true or not ?
there is my result.

Because this is still wrapped phase, stamps(6,6) is the unwrapping step, after applying it, apply step 7, then reapply step 6,
Later on, apply, ps_plot(‘u-dm’)
We’ll compare the results then,

1 Like

thanks for your reply
I did what you said.
and this is result:

is it normal?

You could now apply, ps_plot(‘u-dmo’) to visualize the unwrapped interfergrams with the subtracted ramps, then it’s possible to check up how much the Interferogrms are smooth and well unwrapped.

1 Like

this is result of ps_plot (‘u-dmo’):

it seems most of them smooth. should I add any of them to
scla_drop_index and rerun Step 7?

Would you please to take a look at my case,

Source of the post

Please read this post,

Source of the post

Hi Katherine, can you please tell what is the solution to this problem ? My pscands.1.ij file is empty too …

if this file is empty it is probably related to a bad interferogram. when running mt_prep_snap check the mean amplitude(should not be zero) and amount of cells with 0 amplitude(should not be higher than cells with amplitude). you can also visually check the interferograms in SNAP. @houda

so if i have a bad interferogram i have to delete from diff0 and rsc the files that have the date of the bad inteferogram ? Is this solution enough to correct the problem? @Gijs thank you for your time

@houda yes if you remove all files containing the date of this ifg in the stamps_export folder this date will not be processed in mt_prep_snap and i should solve the error.

you could also try to reprocess that date and maybe that will fix the file, common problems are:

  • accidentally putting a descending file in your ascending file (or vice versa)
  • accidentally split the wrong subswath
  • accidentally put file of different path/frame in the project folder

i have also had cases where the Sentinel 1 file was just corrupt :frowning:

but just removing the date will solve your problem.

Hey everybody,

a small question:

When plotting a time series plot on ps_plot(‘v-do’,‘ts’) for some reason the interferograms i have listed in drop_ifg_index and scla_drop_index are still shown.
i redid the processing with drop_ifg_index from step 1 again so i am not sure how this data is still showing.
do you guys have any clue?

Did you followed this,

If there are unwrapping errors in some images, you can drop them from the spatially-
correlated error estimation. E.g. to drop the 2nd and 24th interferograms

Then rerun Step 7.


StaMPS Persistent Scatterer Exercise
ESA Land Training Course, Bucharest, 14-18th September, 2015

this is not my question, and yes ofcourse i have done this.

drop_index looks like this [1,2,3,4,6,7]

but for some reason ifg 3,4,6,7 still show as ts points in the v-do ts plots

I got your question mean very well, but I’m asking if you drop those unwanted correctly,

Use the command such as
setparm(‘scla_deramp’,‘y’) If you want to apply it, or
setparm(‘scla_deramp’,‘n’) if you do not want to apply it

yes of course i did :slight_smile:

if i type getparm it shows the correct value and this also gets reflected when running the stamps steps.

Is there anybody who can enlighten me? (@thho @ABraun @mdelgado :slight_smile: )
i am quite stuck since these ifgs really do not fit the data and implement too much noise.

as @falahfakhri already discussed with me, i have indeed set the parameter correctly and it does reflect when the stamps steps run but somehow the dates still show in the timeseries plots.

I am not sure you are using properly the command to plot the ts not considering the dropped ifgs. Please check the full usage of the ps_plot function.

Still, I am not fun of dropping data for ‘introducing noise’ as it is not really noise, but signal with unknown behavior, and this is what science does… get the answer to the unknowns. Still… try to plot it using full command (or try to restart StaMPS from mt_prep_snap step by removing the data you do not want to)

you mean that even though i have dropped the ifgs i still have to plot like this:
psplot(‘v-d’,1,0,0,[1:3,7:8],‘ts’) ?

And @mdelgado , I am working on a permafrost area so the dates i want to throw out are when ice was still on the ground or dates during heavy snowfall. But thank you for the tips anyway.

I guess so, try to use the full command and let us know.

Dear Andy, I’d like to raise this issue once more, concerning python, Would you please to take a look at the following discussions and give me your opinion,

Source of the post