Workflow between SNAP and StaMPS

I got this report but I am unable to solve the issue even then. your kind help will be appreciated that how to solve it.

   Segmentation violation detected at Sat Jun 19 00:38:49 2021 +0500

Crash Decoding : Disabled - No sandbox or build area path
Crash Mode : continue (default)
Default Encoding : UTF-8
Deployed : false
Desktop Environment : ubuntu:GNOME
GNU C Library : 2.31 stable
Graphics Driver : Unknown software
Java Version : Java 1.8.0_152-b16 with Oracle Corporation Java HotSpot™ 64-Bit Server VM mixed mode
MATLAB Architecture : glnxa64
MATLAB Entitlement ID : 6257193
MATLAB Root : /usr/local/MATLAB/R2018b
MATLAB Version : (R2018b)
OpenGL : software
Operating System : Ubuntu 20.04.2 LTS
Process ID : 2737
Processor ID : x86 Family 6 Model 78 Stepping 3, GenuineIntel
Session Key : 24033645-3378-447c-a803-d921c793f6d0
Static TLS mitigation : Disabled: Unnecessary 1
Window System : The X.Org Foundation (12009000), display :0

Fault Count: 1

Abnormal termination

Register State (from fault):
RAX = 00007fa1687fcd10 RBX = 00007fa168b5a400
RCX = 00007fa11f56cb30 RDX = 0000000000000000
RSP = 00007fa11f56cb28 RBP = 00007fa169700bf0
RSI = 000000001000e652 RDI = 00007fa168b58b10

R8 = 0000000000000014 R9 = 00007fa135df85f0
R10 = 0000000000000014 R11 = 000000001000e652
R12 = 00007fa16901fd84 R13 = 0000000000000001
R14 = 0000000000000001 R15 = 0000000000000014

RIP = 0000000000000000 EFL = 0000000000010202

CS = 0033 FS = 0000 GS = 0000

Stack Trace (from fault):
[ 0] 0x0000000000000000 +00000000
[ 1] 0x00007fa135df8645 /lib/x86_64-linux-gnu/
[ 2] 0x0000000200000004 +00000000

You should report this to Matlab. They may already have a solution, if not they may ask for a minimal example that demonstrates the bug.

Thank you for your response, I will do it.

Better reinstall matlab and try it.

Thank you. Sure!

Hello everyone! I am facing this issue when I run stamps(4,4) and Matlab shuts down on its own without any notification.
I have reinstalled Matlab2018b, StaMPS, and SNAPHU. Have tried some solutions given on the internet.
But nothing works for me. Is this error is due to any other problem like any other application that needs to install or any step needed to do prior to the 4th step or any other thing I can do to solve it?

Thank you so much, everyone! your kind response is highly appriciated.

although the solution refers to a different problem, it could help to compile the stamps scripts with the correct compiler as described here: Segmentation Fault (core dumped) error during mt_prep_snap

Tried! Does not work. Still same problem.

Greetings! Kindly check that my config paths are correct or not?

It is easier to search and respond to messages posted as text. We can’t know if all the
settings are correct (line 9 refers to triangle-bin package, but we can’t know if it is installed) but certainly line 10 looks odd (and unlike the example). In general, linux requires some extra steps to allow one user (e.g., “/home/sadi”) to use files in another user’s (e.g. “/home/ahooper”) home directory.

I have installed triangle and Snaphu successfully. I use “whereis” command to find the path of the software. But as you say line 10 looks odd. Can you please guide me the other way to locate the software?

Thank you for your kind response and guidance.

I think SNAPHU should only contain the path to the script, so you can remove the second part (usr/share/…snaphu.1.gz). But this should not cause the problem you mentioned in the first post.

The file looks alright, you don’t need to modify the other lines because they are not included when data is preprocessed with SNAP.

Whenever you open a new terminal, you have to call (source) this file, before all commands are found. What happens when you type snaphu or triangle?

Thank you sir for your time.

Although I have started processing in SNAP again. But I don’t find the reason for the problem that is why willing to know.
Is it possible that I have done anything wrong in SNAP Processing as my first three steps go very smoothly without any error every time I do?

it is a good sign that snaphu and triangle are recognized.

are you sure that you have typed the command correctly? mt_prep_snap
this script should be inside the StaMPS-4.1-beta\bin folder

yes script is in.
mt_prep_snap MasterImage RouteToMyStampsExport/ 0.4 1 1 50 200
Like This:
mt_prep_snap 20200326 /media/sadi/WORKDIR/INSAR_20200326/ 0.4 1 1 50 200

sorry, I was browsing the forum on my phone and confused your issue with this one. Obviously, all scripts run fine on your side.
As your error occurs during step 4, there could be something wrong with the unwrapping.
Maybe this solution is an option: It requires to compile snaphu on your own (instead of apt-get), so first removing the existing instance is required. I cannot guarantee if this will solve your problem (although the error message is quite similar), but if you are familiar with compiling scripts, it could be worth a try.

Thank you so much, Sir! I just try maybe it works. I will come back to you soon hopefully with some positive response. :slightly_smiling_face:

1 Like

Installing 3rd party packages with “sudo” may result in user configuration data being owned by “root” and/or being stored in root’s home directory. Complex packages often lag behind changes in the OS or have only been tested in one OS, so may overwrite critical OS programs.

Using the whereis command explains why you had a man page in one of your environment variables. Also, your X_BIN variables sometimes refer to the bin directory where a program can be found and sometimes give the full path of the program. The documentation always shows the path to the bin directory where the program has been installed.

Is there a guide/tutorial of SNAP-to-StaMPS worflow, for time series creation? It would be much appreciated