Workflow between SNAP and StaMPS


#110

Thanks Katherine for your help
i’ve changed the server and it works ( but the computer properties are weak small RAM, little speed,…)
For the earlier server, i’ll try to install package libgfortran3 as explaned to me Lukas ( post of NativeBlas. Gdemm error)


#112

Hi
Please how do you run mt_prep_gamma in cygwin
I got the messqge error mt_prep_gamma command not found


#113

should be found if you installed stamps correctly.

How did you install it?


#114

thank you Braun for your help
in cygwin i go the src folder in stamps where i type make make install


#115

usually this copies the required scripts to your bin folder where they are made available from any location. Can you move to the folder where mt_prep_gamma is located and run it from there to see if it generally works?


#116

please a question when using cygwin which package do you install because i did it and it doesn t work
and maybe i don t know how to run it (it necessites only to write this command in cygwin mt_prep_gamma without changing anything in the script?)


#117

make and gcc-core

Was your installation of stamps successful? Any error messages?


#118

yes it doesn t show me any error message and also i use as package make and gcc core
in addition for the path for cygwin is /cygdrive/d/… for the master data directory it s like this mt_prep_gamma/cygdrive/d/INSAR_20160227/0.4

and for the configuration we need to do it because i4ve changed the path by /cygdrive/c/windows/temp/StaMPS/
and add this command source StaMPS_CONFIG.bash right?


#119

I don’t know if it works with full path names. Yo usually navigate to the directory above the master data folder and just enter mt_prep_gamma INSAR_2016…

I’m not an expert in configuring cygwin, sorry.


#120

Dear all,
I used SNAP to prepare StaMPS input files and I hadn’t problem with matlab elaboration, but when I analyzed results of StaMPS I understood that some interferograms were wrong.
I checked carefully all steps of workflow in SNAP and I realized that the problem is in TopoRemove tool with stack: in particular, topographic phase are not removed properly in some interferograms (my stack is formed by 8images and only 3 interferograms are ok after topo remove).
Has anyone else had the same problem?
Thank in advance for your help.


#121

Hi Sysrq308 i exported data and run mt_prep but how have you done running stamps under cygwin?


#122

Hi annamaria i didn’t get this error jut rerun them by snap and it will work


#123

Hi BRAUN i finally run mt_prep but to run stamps in cygwin it doesn’t work especially that matlab is on windows and scripts are bash scripts how did you do it


#124

Thank you for your answer!
Unfortunately, however, I’m not able to solve the problem.
In the image you can see 4 maps: in the first line there are the phase maps obtained by removing the topographic phase carried out on the stack; in the second line there are the results that I get by removing the topographic phase by processing on the single pair of images. In the second line are very evident the interferometric fringes: this result is consistent with reality (I compared results with GPS), while the results that I obtained with the stack are affected by evident problems.

So, at least in my case, the results obtained through the topographic phase removal tool with stack are useless.


#125

i understand you . in my opinion if you get results by processing on single pair of images which are compatible with gps results , you are in the good way because at least it must be images stack and pair interferograms.
Please annamaria i’m having problems to compile stamps with matlab please tell me have you worked in windows or in lunix and what is the performance of your pc (space, RAM, processor, … because i didn’t go on in this study


#126

Dear soukainamez,

Single pair results are ok, but “stack results” are mistaken, so I have given up using the suggested workflow between Snap and StaMPS. :cry:

I’m not expert of cygwin and windows: I use only ubuntu.
I don’t undestand well what is your problem, however, if you don’t able to run stamps in matlab after mt_prep, i think the problem is that matlab don’t find stamps functions. So, You could add path of stamps function to your work directory (for example in ubuntu _addpath(’/home/annamariaStaMPS_v3.3b1/matlab’) ) and it would run.
My laptop has 1Tb of hard disk, Intel® Core™ i7-7700HQ CPU @ 2.80GHz × 8 , Ram 16Gb.


#127

Hi annamaria, my suggestion is that you may check the source code and try to debug to see where is going wrong, since you have got the correct single pair results and have some correct interferogram in stack, it’s too pity to give up now. And I think it won’t be too much code you should check, the source code about topo_phase_removal I found here: https://github.com/senbox-org/s1tbx/blob/2a7417eb758386ab59417bda0545efe7b13a525a/jlinda/jlinda-core/src/main/java/org/jlinda/core/geocode/DInSAR.java

Or, I heard that the beta version of Doris5 has been released on github, it said can process stack of Sentinel1 data, maybe you can give a try, if this can work, please let me kown:slight_smile:


#128

Dear FeiLiu
thanks for your help.
At this time I bypassed the problem: I created a stack with results of single pairs elaborations and I didn’t had problems with StaMPS export and with matlab elaboration. My personal workflow requires much more time, but until I understand what is the oringin of the problem, I will use this procedure. i can’t do anything else.
I can not explain why I’m the only one who has this problem.
In any case, as soon as possible I’ll check the code (I don’t know java language, but i’ll try). If I’ll use Doris, I will keep you updated. :wink:


#129

hi annamaria me too i had problem in exporting interferograms of stack to stamps. It worked to me in first time with 5 images but i found problem in matlab compilation when i rerun it it doesn’t work always errors even if i follow instructions of workflow but now i ll redo it with ubuntu and i wish that it works


#130

thank you for replay annamaria i will retry with ubuntu