Wrong operation mode sen2cor v2.8

Hi there,

sen2cor processor fails in batch with the following error:
“wrong operation mode: None”

I understand this is an issue with the configuration file.
The correct configuration file can be specified in command line with the --GIP_L2A option.
Unfortunately, I end up with the same error even in this case.
It sound like the option was ignored

Can you provide any support on that?

Apart from the sen2cor/2.8/cfg/L2A_GIPP.xml in the home, what does L2A_Processor needs?



Is this forum still active???

This forum is still active.
@FlorianD can you have a look?

its seems the -GIP_L2A option does not take into account the specified config file.
it still uses the /home/…/sen2cor/cfg/L2A_GIPP.xml one.

can you explain how to correctly use this option in command line?



Did you put a full path into --GIP_L2A option, or a relative path?

I put the full path.

the L2A_bashrc specifies the path to the configuration file.
The default is in the user home.
I can edit the bashrc file with a different path but that is not ideal.

Can you paste here the entire command?
Maybe it’s something else…

here it is

Why are 2 slashes // there?

not because of that.

Your command line seems OK…
Is there any symlink in your path?

If you mean symbolic link, yes the S2L1C is indeed a symbolic link but I think I tried to hard copy it to do some tests.
I can double check that.

Yes, by symlink I mean symbolic link :slight_smile:

I would also suggest to copy your L2A_GIPP.xml in a shorter local path, without any symlink.
The way it looks, maybe you build it (obtain it) using some variables, and maybe the resulted path is not correct.

The problem is the “=” sign :slight_smile: after the --GIP_L2A option
It should be:
–GIP_L2A /work/PATH2sen2cor_Install/sen2cor_v2.8/Sen2Cor-02.08.00-Linux64/lib/python2.7/site-packages/sen2cor//cfg/L2A_GIPP.xml

(replace the “=” with " ")